SPONSORS:






User Tag List

Results 1 to 7 of 7
  1. #1
    Member
    Join Date
    May 2001
    Location
    Houston, TX USA
    Posts
    40
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    *** Error: Application not ready

    I have a Browser Control in my application and I am click on that control and I am getting the following error:

    *** Error: Application is not ready
    Occured in WaitForReady

    Did any one saw this error and any suggestions?

    Thanks

    ------------------
    SG
    SG

  2. #2
    Member
    Join Date
    May 2001
    Location
    New York, NY, USA
    Posts
    64
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: *** Error: Application not ready

    Hard to say what the exact cause is. Are you trying to click on the object, or on the application? Is it the active application? Make sure you first click on the application and make it the active app, and then click on the browser control object.

    -Zareh

    ------------------
    Amelior Technology
    zarehk@ameliortech.com

  3. #3
    Member
    Join Date
    Feb 2001
    Location
    New York, NY
    Posts
    41
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: *** Error: Application not ready

    It sounds like your application takes too long to come up and Silk times out. The simple solution is to increase the timeout values.

    This can be set globally of for individual script:
    Agent.SetOption (OPT_APPREADY_TIMEOUT, 180)

    Another value to set is
    number nInvokeTimeout= 150

    This is added to your frame file for the main window declaration.


    ------------------
    -Lev Aks
    lev_aks@in-nyc.com

  4. #4
    Senior Member
    Join Date
    Jun 1999
    Location
    Fremont, CA, USA
    Posts
    355
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: *** Error: Application not ready

    If you need to wait longer just for that window, you could just use:

    Browser.WaitForReady(200) // or whatever time.


    If the page might take a really long time, but you don't know if it will be 5 seconds or 5 mintues, do something like:

    This will then sit and wait until the window object that your waiting for exists.


    ------------------
    David Genrich
    david@e2Open.com
    david_kim@usa.net

  5. #5
    Junior Member
    Join Date
    Mar 2001
    Location
    Pune,Maharashtra,India
    Posts
    22
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: *** Error: Application not ready

    <BLOCKQUOTE><font size="1" face="Verdana, Arial, Helvetica">quote:</font><HR>Originally posted by gadagoju:
    I have a Browser Control in my application and I am click on that control and I am getting the following error:

    *** Error: Application is not ready
    Occured in WaitForReady

    Did any one saw this error and any suggestions?

    Thanks

    <HR></BLOCKQUOTE>


    Try this

    Insert this line at the beginning

    Agent.SetOption (OPT_VERIFY_APPREADY, FALSE)

    Hope this will help you.

    Regards,
    Pratibha



    ------------------

  6. #6
    Junior Member
    Join Date
    Dec 2005
    Location
    NY
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: *** Error: Application not ready

    Hi all,

    I'm experiencing this error as well. However, this error only occurs when the script is executed by another user ( other then the user that installed Silk Test) I've experimented with users with machine Admin rights to no avail. Has anyone else experienced this issue?

    Thanks

  7. #7
    Senior Member
    Join Date
    Jan 2003
    Location
    Portland, ME USA
    Posts
    603
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: *** Error: Application not ready

    I see this error, but it's not consitant. Could be a computer issue, but when the error occurs the web page is not loaded at all, IE is up and running but the page did not load. This one puzzles me??

    Thanks in advance
    N+ CNA

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 12:46 PM.

Copyright BetaSoft Inc.