SPONSORS:






User Tag List

Results 1 to 2 of 2
  1. #1
    Guest

    Inconsistent object recognizition in Silk 5.5

    I am having problems with window identifications.
    I am having a module explorer which contains tree view and task bar,
    when I record window It looks like following:

    [+] CustomWin OLEModuleExplorerCtrl1
    [ ] msw tag "[OLEModuleExplorerCtrl]#1"
    [+] TreeView TreeView1
    [ ] tag "$100"
    [+] ToolBar ToolBar1
    [ ] tag "$101"
    [+] PushButton PushButton1
    [ ] tag "$35495"
    [+] PushButton PushButton2
    [ ] tag "$35496"
    [+] PushButton PushButton3
    [ ] tag "$35497"

    When I try to access the tree view for the first time silk sucessfully accesses it but next time around.
    when I try to access the tree view say when I have to collapse or expand it silk errors out saying OLEModuleExplorerCtrl1 not found.

    So I tried to record the window identifier with the help of record>window identifier and the identifier in the second time was.

    [+] CustomWin Afx40000001
    [ ] msw tag "[Afx:400000:0]$12022"
    [+] CustomWin OLEModuleExplorerCtrl1
    [ ] msw tag "[OLEModuleExplorerCtrl]#1"
    [+] TreeView TreeView1
    [ ] tag "$100"
    [+] ToolBar ToolBar1
    [ ] tag "$101"
    [+] PushButton PushButton1
    [ ] tag "$35491"
    [+] PushButton PushButton2
    [ ] tag "$35492"
    [+] PushButton PushButton3
    [ ] tag "$35493"


    Why is SILK recognizing same object in two different ways? Before this I was using silk 5.0.1 and there was no problem silk was recognizing the objects in a consistent way.

    application in developed in vb
    ------------------


    [This message has been edited by jbarlinge (edited 10-01-2001).]

  2. #2
    Senior Member
    Join Date
    Jul 1999
    Location
    Burlingame CA 94010
    Posts
    502
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Inconsistent object recognizition in Silk 5.5

    It's difficult to tell without seeing it, BUT, maybe, after you access it, it is being repainted with a new parent object, as shown in your declarations.

    Try using "Record Window identifiers" and "Record Actions" to manipulate the treeview, then paste the results.



    ------------------
    John W Green
    jwgreen@automationexpertise.com
    http://www.automationexpertise.com

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 05:48 AM.

Copyright BetaSoft Inc.