SPONSORS:






User Tag List

Results 1 to 7 of 7
  1. #1
    bob
    bob is offline
    Junior Member
    Join Date
    Jul 2001
    Posts
    21
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Agent Error at HasFocus().

    Hi,

    SilkTest5.5 (3rd fix)IE5.5
    I am getting the 'Internal error in agent - Child not found' at HasFocus(). To reproduce I found the site with frames.
    Look for Declarations in the attachment file.
    Here is the script:
    [-] testcase Test3 () appstate DefaultBaseState
    [ ] Browser.LoadPage ("http://www.garthtoombs.com/services-frames.htm")
    [ ] HttpWwwGarthtoombsComSer.SetActive ()
    [ ] HttpWwwGarthtoombsComSer.GARTHTOOMBSTOPNAVIGATION. Menu2.Click (1, 64, 11)
    [ ]
    [ ] BOOLEAN bFocus
    [ ] bFocus = HttpWwwGarthtoombsComSer.GARTHTOOMBSSERVICESNAVIGA .HttpWwwGarthtoombsComPsy.HasFocus ()
    [+] Print (bFocus)
    [ ]
    [ ]

    I don't get the error if no frames .
    Seague says it because, I quote
    "The problem with the last test was that html links cannot use the HasFocus
    () function.

    If you go to the library browser in silktest and check the 'include
    inherited' checkbox, then scroll down until you see htmlLink, you will see
    that the HasFocus is included in the list on the right.

    Let me know if you find a suitable web-site so that we can test the
    textField with the HasFocus() function."

    First, In our application under test which has frames, it fails for any control.
    Second, I am a little supprised they don't have a test application to try it.

    Anyway, I used this method before - tab to control (not with frames however) and don't see why wouldn't it work. Does anybody know the solution?

    [This message has been edited by bob (edited 09-20-2001).]

    [This message has been edited by bob (edited 09-20-2001).]

  2. #2
    Member
    Join Date
    Jul 2001
    Location
    NY, USA
    Posts
    67
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Agent Error at HasFocus().

    Hi bob,

    Where is the attachment?

    Srikanth

    ------------------

  3. #3
    bob
    bob is offline
    Junior Member
    Join Date
    Jul 2001
    Posts
    21
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Agent Error at HasFocus().

    Sorry, I edited the topic and forgot to include the attachment.

    ------------------

  4. #4
    Senior Member
    Join Date
    Sep 2000
    Location
    Twin Cities, MN, USA
    Posts
    653
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Agent Error at HasFocus().

    I had the same problem with Netscape. The only thing I could come up with was to do a tab to the control to verify focus, and do an area bitmap verification to see if the control was outlined.
    Segue could not help me either.

    ------------------

  5. #5
    Member
    Join Date
    Jul 2001
    Location
    NY, USA
    Posts
    67
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Agent Error at HasFocus().

    Hi Bob,

    I got some other error when I used your .inc
    So I recreated it again assuming you wanted to click on the "psychological" button on the leftside of the frame. HasFocus() returns a false when I run on this page.

    Silk help defines Hasfocus() action as
    'Tests whether the control has input focus.'

    so I tried on the hotmail page that waits for user input (has focus!!). HasFocus() returns true in this case!! I havent considered whether Hotmail page has frames or not.

    Attached is the zip with the frame files and .t files that I used for this.

    Trust I could be of some help to you!!!

    Cheers
    Srikanth

    ------------------
    Habit 1 - "Be Proactive"
    "The 7 Habits of Highly Effective People" by Stephen R. Covey

  6. #6
    Member
    Join Date
    Jul 2001
    Location
    NY, USA
    Posts
    67
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Agent Error at HasFocus().

    I forgot to add that I am using Silktest 5.5 HF3 on Win2k IE5.5 with VO extn enabled

    Srikanth

    ------------------
    Habit 1 - "Be Proactive"
    "The 7 Habits of Highly Effective People" by Stephen R. Covey

  7. #7
    bob
    bob is offline
    Junior Member
    Join Date
    Jul 2001
    Posts
    21
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Agent Error at HasFocus().

    Looks like the problem is apparent with DOM extension and frames. I tried VO and no frames and it was is OK.

    ------------------


    [This message has been edited by bob (edited 09-26-2001).]

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 05:55 PM.

Copyright BetaSoft Inc.