SPONSORS:






User Tag List

Results 1 to 3 of 3
  1. #1
    Senior Member
    Join Date
    Jul 1999
    Location
    New York, NY, USA
    Posts
    137
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Help - Silk 5.01 Window ID tags

    I am trying to move up to SILK 5.01 for my current project and I have encountered an old problem For some frames in my web app they have the same text headings but different content. I have always coded around this in the past using the Windows ID tag. In silk 5.0 the window ID returned the literal address of the object with IE 4.0. Now I a getting "$0". There used to be a piece if magic code for the Agent (Empty Images Locations...) but I can't find it and don't remember it exactly.

    Has anyone worked around this issue yet? Is so please send me the answer ASAP, I am going to contact Segue and open an issue, I will roll-back Silk in a couple of hours If I dont have an answer.

    Note (10/22/99)- This is only happening in the BrowserChild Tags, Images and Links are not affected.


    Thanks,
    Tom
    woodmant@mmanet.com

    [This message has been edited by woodman (edited 10-22-1999).]

  2. #2
    Guest

    Re: Help - Silk 5.01 Window ID tags

    If you have two browser frames that are not unique, and no control ID's are found, then you have to refer to a child window in the actual window tag to make it unique. Example:

    window BrowserChild NetscapeHome
    tag "[BrowserChild]#1/[HtmlLink]My Netscape/.."

    ...

    The other browser frame will have a different child window control reference. The key is that /.. at the end of the tag.

  3. #3
    Senior Member
    Join Date
    Jul 1999
    Location
    New York, NY, USA
    Posts
    137
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Help - Silk 5.01 Window ID tags

    Sorry,

    That's not the problem. The problem is that both frames have the same HtmlHeading but are unique. I can just put all of the unique objects under the same BrowserChild but this gets out of hand very quickly. I also am far enough into my current project that I would have to modify a great deal of code. It is one of those situations where I need a unique tag that isn't coming from the text label, and it isn't an Index (which I usually avoid at all cost).

    It is definitly a bug which has been reintroduced by Segue, I had a previous issue open with them on it. I also did some beta testing on Silk 5.0 and they had fixed it. The release version of 5.0 is fine, it is only happening in the 5.0.1 release.

    In 2.1.4 they had some undocumented agent settings that would fix this for Netscape, but it hung under IE 4.01. I don't think the previous workarround they gave me will work this time because I am locked into testing under IE 4 and up.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 04:20 PM.

Copyright BetaSoft Inc.