SPONSORS:






User Tag List

Results 1 to 4 of 4
  1. #1
    Senior Member
    Join Date
    Nov 2000
    Location
    Bloomington, IL
    Posts
    142
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: SilkTest stumbles on HtmlPopupList

    Search the forum (Top right hand corner for HtmlPopupList. Use the advanced button to limit your searchs to SilkTest. You'll get about 30 hits under SilkTest.

    MikeF

    ------------------

  2. #2
    Junior Member
    Join Date
    Aug 2001
    Location
    Burlington, MA, USA
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    SilkTest stumbles on HtmlPopupList

    Hi:

    In my testcase Silk needs to select an entry from an HtmlPopupList. Until now it did it with no problems. With a new build, it opens the PopupList, selects an item preceeding the one specified by the testcase, places this (wrong) entry in the box, then says that the control does not respond. Nothing has changed around this control in the new build. It gets recognized by the Window Identifier without problems, but stumbles on the Select method.

    Does anybody know what may be the couse of this?

    Thanks,

    Mark

    ------------------

  3. #3
    Senior Member
    Join Date
    Jul 2000
    Location
    Walsall, West Midlands, United Kingdom
    Posts
    259
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: SilkTest stumbles on HtmlPopupList

    You may have a problem if the popup is at the edge of the screen.

    If this is the case, you may need to put some code in to scroll the page a little, prior to selecting, so that when the popup is expanded it remains within the current screen.

    ------------------

  4. #4
    Senior Member
    Join Date
    Jul 2001
    Location
    Westford, MA, USA
    Posts
    160
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: SilkTest stumbles on HtmlPopupList

    Ditto to what MikeF said -- all this has been discussed to death in this forum, and resolved. Make sure you're using SilkTest 5.5 DOM (there is no fix if you're seeing breakage in 5.0.3x, btw). Install Hotfix 3, and write this line to your Extend\domex.ini file, under [Options]:
    UseDocumentEvents=FALSE

    -AG



    ------------------

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 11:08 AM.

Copyright BetaSoft Inc.