SPONSORS:






User Tag List

Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Junior Member
    Join Date
    Sep 2000
    Location
    ca
    Posts
    12
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    SetBaseState () problem.

    Is anyone experiencing the SetBaseState () being not working at all under 5.0.1? It just jump out of the function if you try to step into it.
    Anyone else is having this problem?

  2. #2
    Junior Member
    Join Date
    Jul 1999
    Location
    Austin, TX. USA
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: SetBaseState () problem.

    I think (but not sure) SetBaseState() is a built-in function, therefore, you can't step in to it with the debugger.
    Kendall Schmidt
    Vignette Corporation
    kschmidt@vignette.com

  3. #3
    Member
    Join Date
    Oct 1999
    Location
    Austin, TX, USA
    Posts
    32
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: SetBaseState () problem.

    Could you give us more info on what you are doing? Why are explicitly calling SetBaseState? It's usually called on TestcaseExit. Perhaps you need SetMultiAppStates (in the event you are doing parallel testing).

    Cynthia

  4. #4
    Junior Member
    Join Date
    Sep 2000
    Location
    ca
    Posts
    12
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: SetBaseState () problem.

    Yes, your are right on the TestCaseExit () but if you step into TestCaseExit, it calls SetBaseState on the very last line of the function. Currently, it just doesnt seem to be working with 5.0.1.
    Is it me or anyone out there also having the problem. I am running on NT w/ sp5

    Thanks,
    Tony

  5. #5
    Guest

    Re: SetBaseState () problem.

    You are indeed correct. SetBaseState() does appear to be broken in Silk 5.0.1. I have several appStates that perform cleanup operations if GetTestCaseState() returns TCS_EXITING, but these operations are not occurring because the appStates are no longer being called at test case exit.

    It appears that the call to SetBaseState() in DefaultTestCaseExit() is non-functional.

    Our test environment is Win95 and Win98.

    Tony Mrozinski
    Intel Corporation

  6. #6
    Junior Member
    Join Date
    Sep 2000
    Location
    ca
    Posts
    12
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: SetBaseState () problem.

    It is cool to know I am not the only one that is encountering the problem. With that settle, how are you guys get around the bug? Segue tech support is utterly worthless right now. It has been 2 weeks and I have yet recieve an update or respond...

  7. #7
    Guest

    Re: SetBaseState () problem.

    Tony:
    I just found the SetBaseState() bug an hour ago and have yet to come up with a workaround. I did report the bug to our contact in Segue Solution Support and he has promised to have it looked into right away (sometime, being part of the big Intel beast has it's advantages).

    For now, we'll continue to rely on the patched version of SilkTest 5.0. We have a lab with 20+ target test systems running constantly so we don't install any new software from Segue until we've thoroughly tested it on a small 3 system debug rack under Win95 and Win98. We no longer deploy new Silk releases on our production test systems until we have very thoroughly tested it as we have found too many potentially crippling bugs.

    If Segue responds to us with a workaround or patch to the SetBaseState() issue, or if we come up with our own workaround, I'll post the info here. Good luck...

    Tony Mrozinski (the other Tony)
    Intel Corporation

    [This message has been edited by Tony Mrozinski (edited 10-14-1999).]

  8. #8
    Junior Member
    Join Date
    Sep 2000
    Location
    ca
    Posts
    12
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: SetBaseState () problem.

    Thanks Tony...

    I got this guy rsherrard@segue.com to help me but so far, NOTHING. Perhaps the word Intel should put the problem on a higher queue.

    Tony Lam (Not the big INTEL tony)

  9. #9
    AJ
    AJ is offline
    Moderator AJ's Avatar
    Join Date
    Jun 1999
    Location
    San Jose, CA
    Posts
    1,691
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: SetBaseState () problem.

    To the other Tony: (unregistered)

    Why not register? At least this way we can tell which one's which.

    ------------------
    AJ Alhait
    BetaSoft Inc.
    AJ Alhait
    BetaSoft Inc.

  10. #10
    Member
    Join Date
    Oct 1999
    Location
    Austin, TX, USA
    Posts
    32
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: SetBaseState () problem.

    News from Segue: Product Management still hasn't made the decision as to whether there will be a patch or if the fix will be in the next maintenance release (5.0.2).

    No estimated timeframe yet, though....

    -Cynthia

 

 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 10:39 PM.

Copyright BetaSoft Inc.