SPONSORS:






User Tag List

Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    May 2001
    Location
    Plainsboro, NJ, USA
    Posts
    28
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    SilkTest5.5 browser message problem

    Hi,
    With SilkTest5.03 whenever browser message dialogbox popups with the following command, it used to run successfully.
    BrowserMessage.SetActive ()
    BrowserMessage.OK.Click ()

    Now I installed SilkTest5.5 and when the browser message dialogbox popups it is generating the following error.

    *** Error: Window '[MainWin]$explorer5[1]' was not found
    Occurred in BrowserMessage.SetActive

    When I run in the debug mode the script is failing in the SilkTest-Extend-htmlpage.inc- winclass BrowserChildRoot : AnyWinfile-hidecalls SetActive ()

    Will some one solve my problem.

    Thanks in advance

    Vinod Madhikar

    ------------------


    [This message has been edited by madhikar (edited 06-20-2001).]

  2. #2
    Junior Member
    Join Date
    Jun 2001
    Posts
    29
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: SilkTest5.5 browser message problem

    Verify that you have the correct browser default settings in Options/Runtime. Make sure that this is the same as the one in Options/Extensions. Also check that these browsers are the same as the one set in the Extension Enabler (the separate application found in the SilkTest folder in Programs).

    Furthermore, check that you can run the DefaultBaseState function without errors. To run the DefaultBaseState, go to Run/Application State

    ------------------

  3. #3
    Senior Member
    Join Date
    Jul 1999
    Location
    Burlingame CA 94010
    Posts
    502
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: SilkTest5.5 browser message problem

    It sounds like the dialog is not being recognized as BrowserMessage any more. Bring the dialog up manually, then use Record - Window Identifiers to check how Silk recognizes the dialog.

    Hope this helps

    ------------------
    John W Green
    jwgreen@automationexpertise.com
    http://www.automationexpertise.com

  4. #4
    Member
    Join Date
    Aug 2002
    Location
    Raleigh
    Posts
    31
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: SilkTest5.5 browser message problem

    Sorry to bring up a thread this old, but I'm having a similar problem. I've been running testcases that use BrowserMessage.OK.Click() on the dialog boxes, and it's been working fine. Until I ran into one today. No matter what I try, I cannot seem to figure out a workaround. I get the same error as listed before, it's not recognizing this particular dialogbox. And it's being created in the code with a call to the exact same method that's being called in other dialog boxes that silk recognizes. I'm stumped.

    [ ] BrowserMessage.SetActive ()
    [ ] BrowserMessage.OK.Click ()

    that should work. Anybody else have this problem?

    ------------------

  5. #5
    Member
    Join Date
    Aug 2002
    Location
    Raleigh
    Posts
    31
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: SilkTest5.5 browser message problem

    Okay, so I got it to work by clicking on the message in the middle of the dialog box. That doesn't make any sense to me at all why it would work now. Here's the code:

    [ ] BrowserMessage.SetActive ()
    [ ] BrowserMessage.Message.Click ()
    [ ] BrowserMessage.OK.Click ()


    that's way different from my:

    [ ] BrowserMessage.SetActive ()
    [ ] BrowserMessage.OK.Click ()


    Here is the error I was getting:

    [ ] *** Error: Window '[DialogBox]$MessageBox' was not found
    [ ] Occurred in SetActive
    [ ] Called from SetupPriceList at LM.t(107)
    [ ] *** DefaultBaseState is closing Browser windows
    [ ] Closing BrowserMessage


    Now I'm trying to recreate the error by commenting out the Message.Click(), but it's not failing anymore. Does anyone have an explantation other than Silk is flaky?

    ------------------

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 05:42 AM.

Copyright BetaSoft Inc.