SPONSORS:






User Tag List

Results 1 to 7 of 7
  1. #1
    Member
    Join Date
    May 2001
    Location
    Santa Clara, CA, USA
    Posts
    57
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Pushbutton seen as HTMLTextField ???

    I have attached a jpg file which has a HTML Text and a Pushbutton. But silk does not recognise the button as pushbutton but sees it as a HTML Textfield. The window decleration for the same are as shown below or as shown in the Txt file. Could anyone tell me if I am doing something wrong ?

    Thanks

    [+] HtmlTable Import
    [+] multitag "Import"
    [ ] "#1"
    [+] HtmlColumn HtmlColumn1
    [ ] tag "#1"
    [+] HtmlText UploadFile
    [+] multitag "Upload file"
    [ ] "#1"
    [+] HtmlColumn HtmlColumn2
    [ ] tag "#2"
    [+] HtmlTextField UploadFile
    [+] multitag "Upload file"
    [ ] "#1"
    [ ] "$UploadedFile"

  2. #2
    Member
    Join Date
    May 2001
    Posts
    56
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Pushbutton seen as HTMLTextField ???

    Hi Devu,
    What version of Silk you using. And one more thing did you attached real jpg file. Because I am using silk 5.0.3.1 on WinNT and it recognizes pushbutton as an HtmlImage.



    ------------------

  3. #3
    Member
    Join Date
    May 2001
    Location
    Santa Clara, CA, USA
    Posts
    57
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Pushbutton seen as HTMLTextField ???

    I am using 5.0.3.2.
    And I have the pushbutton problem only at 2 places rest all works fine. Its only in 2 screens that it sees it as a HTMLTextField

    ------------------

  4. #4
    Senior Member
    Join Date
    Jul 2000
    Location
    Walsall, West Midlands, United Kingdom
    Posts
    259
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Pushbutton seen as HTMLTextField ???

    Devu,

    It might be a good idea if you had a look at the HTML source or attach it in the post to ensure it is written properly, e.g. does the input sit in the form tags.

    Cheers.

    ------------------

  5. #5
    Member
    Join Date
    Jun 2000
    Location
    Derby, UK
    Posts
    37
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Pushbutton seen as HTMLTextField ???

    Hi Devu,
    Ive had similar problem myself however i found a couple of workarounds.

    Solution 1. I also couldnt get silk to identify the pushbutton. However the solution was just to use the click method but click in the region of the button
    i.e
    HtmlTextField.Click (1, 431, 5)

    Solution 2. Couldnt use the control because it is or isnt enabled. So i made a new method for this control that fixed it.

    [-] HtmlTextField TxtFldDataUpload
    [ ] tag "$DaUp_UploadFileName"
    [-] void Open()
    [ ] Agent.SetOption (OPT_VERIFY_ENABLED, FALSE)
    [ ] //had to wrap this in these becuase the window is set as inabled
    [ ] eWare.FrameMain.TxtFldDataUpload.Click(1,450,5)
    [ ] Agent.SetOption (OPT_VERIFY_ENABLED, TRUE)



    ------------------

  6. #6
    Member
    Join Date
    Nov 2000
    Location
    Shelton, CT, USA
    Posts
    32
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Pushbutton seen as HTMLTextField ???

    I've encountered this same problem several times. It appears to be caused by the fact that there are ... in the button caption?? The way that I've gotton around this is to create a "fake" HtmlPushButton object. I then create a simple click function using the coordinates returned from GetRect(). In all instances of this problem the PushButton seemed to be part of the textfield so the GetRect() returns the size of the TextField and PushButton combined. Which makes life easier. In the example below, ThumbnailToUpload is the TextField. I just find the length and back up a few characters to click on the "button" portion of the TextField. Notice you don't use a tag.

    ------------------


    [This message has been edited by mvpl (edited 06-15-2001).]

  7. #7
    Vic
    Vic is offline
    Junior Member
    Join Date
    Apr 2001
    Location
    San Francisco, CA 9416
    Posts
    17
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Pushbutton seen as HTMLTextField ???

    I experience the same problem in Silk 5.032. For your information, it's fixed in Silk 5.5 incase you are contemplating on upgrading or not.

    ------------------

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 02:15 PM.

Copyright BetaSoft Inc.