Please help ! I am new to Silk Test (have not yet taken 4Test Language course) and need assistance. A bit of background I have been recording my Windows Declarations in a frame2.inc file since my upgrade to SilkTest 5.5 but now I cannot get my testscripts to run. Each time the TestScript moves to a different window (other than the default state window)I get the error that the first object from that window in not enabled: [ ] *** Error: Window '[HtmlPushButton]hrs' is not enabled
It will go to the proper Window but as soon as you try to focus, select, click or whatever, you will get this error. Before my Windows Declarations and upgrade all my Testscrips ran fine so I'm thinking it may be just a setting of some sort that's off. These are the things I've tried so far : Options / Agent / Verification - disabled Verify that Windows are active. Options / Agent / Verification - disabled Verify that Windows are enabled; and I've tried a combination of one, the other and both. I've tried putting it in my code along with / without the above selected combination :
Agent.SetOption(OPT_VERIFY_ENABLED,FALSE)
[ ]Tasktypewindow.Btnadd.Click ()
Agent.SetOption(OPT_VERIFY_ENABLED,TRUE)
I have ensured that the frame2.inc file where this (Tasktypewindow) Window is declared is in the Options / Runtime / Usefile path, and to be certain I've put it in my code :
include "frame2.inc"
I've changed the Options / Agent / Timing -Keyboard event delay (seconds)to 0.5 and the Mouse event delay (seconds)to 0.5 .I've also tried different methods of selecting the object like PressMouse, TypeKeys, SetFocus, ReleaseMouse. I cannot use my SilkTest until this problem is resolved can you help me ? How do I enable this window ?



------------------