SPONSORS:






User Tag List

Results 1 to 7 of 7
  1. #1
    Junior Member
    Join Date
    May 2001
    Location
    Santa Clara, CA
    Posts
    2
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Control not responding when use \"Select\"

    Hi,

    I'm using Silk Test 5.0 on Windows 2000. Does anyone know how I can resolve the problem when use "Select" method for treeview, it does not select and gives error message "Control does not respond". The same script works on Windows NT.

  2. #2
    Senior Member
    Join Date
    Jul 1999
    Location
    Bellingham, WA USA
    Posts
    1,323
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Control not responding when use \"Select\"

    Not much to go on here, but this sounds very similar to a problem I was having in a Java application with a JavaJFCTreeView object. The way I got around it was to take the entire tree, dump it into a List of String. Then called GetItemCount() on it. For each {i} in the ItemCount, I was able to call Select() and manipulate it however I wanted. Otherwise, I was seeing the same thing it sounds like you are seeing.

  3. #3
    Senior Member
    Join Date
    Aug 1999
    Location
    Irvine, CA
    Posts
    157
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Control not responding when use \"Select\"

    <BLOCKQUOTE><font size="1" face="Verdana, Arial, Helvetica">quote:</font><HR>Originally posted by silktestuser:
    Hi,

    I'm using Silk Test 5.0 on Windows 2000. Does anyone know how I can resolve the problem when use "Select" method for treeview, it does not select and gives error message "Control does not respond". The same script works on Windows NT.
    <HR></BLOCKQUOTE>

    I have had this same problem ever since trying to test our product in Windows 2000, and I never found a great workaround. You might want to try redefining the Select method for TreeView so that it retries X number of times on a "Control Not Responding" exception. For me this did not help, because once SilkTest gets in a state where selecting TreeView items fails, it always fails.

    What we had to do was try the builtin method once, and if is fails we then execute our "hack" version of Select. It essentially involved clicking the first item in the tree and then typing the down arrow until the item we want is the selected item.

    ------------------
    Matt Gray
    Kofax Image Products
    Matt Gray

  4. #4
    Junior Member
    Join Date
    Apr 2001
    Location
    North Reading, Massachusetts USA
    Posts
    5
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Control not responding when use \"Select\"

    we also had this problem with a JFCTreeView. our workaround was to capture the class using CaptureClass and used an invokeMethods that accessed the setSelection method. i was able to retrieve the int to pass in to the method by using ListFind on the GetContents method. by using setSelection we are not testing the actionevent but we figured we would hit this about a billion times during manual testing!

    ------------------

  5. #5
    Junior Member
    Join Date
    May 2001
    Location
    Santa Clara, CA
    Posts
    2
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Control not responding when use \"Select\"

    Thanks for all your suggestions but I found this workaround to work on Win2000.
    ex:
    STRING sString = "item"
    INTEGER iIndex

    DOES NOT WORK:
    window.treeview.Select(sString)

    DOES WORK:
    iIndex = window.treeview.FindItem(sString)
    window.treeview.Select(iIndex)

  6. #6
    Senior Member
    Join Date
    Jan 2001
    Posts
    750
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Control not responding when use \"Select\"

    Interesting workaround!


    Somehow NT is more supported than WIN2K, don't ask why. Like DOM works better in NT than WIN2K.



    ------------------

  7. #7
    Junior Member
    Join Date
    May 2001
    Location
    Portland, OR
    Posts
    27
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Control not responding when use \"Select\"

    For what it's worth.

    I used a similiar workaround that SilkTestUser details above for selecting a column in a JavaJFCTable in Windows 2000. I was unable to use the column name in the select statement. However, I could use the column name to get it's index then use the index to select it.

    ------------------

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 11:10 PM.

Copyright BetaSoft Inc.