SPONSORS:






User Tag List

Results 1 to 4 of 4
  1. #1
    Guest

    WIERD BEHAVIOUR WITH \"CLICK()\"

    On a VBform when I do click() on a vbcommand button the application and silk hangs, I can only get out of that freeze when i do ctrl+alt+del and then cancel.

    but if I do click(1,1,1,true) it works fine any idea????

    OS is NT and applicaiton is built in VB


    ------------------

  2. #2
    Senior Member
    Join Date
    Jul 1999
    Location
    Burlingame CA 94010
    Posts
    502
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: WIERD BEHAVIOUR WITH \"CLICK()\"

    It sounds like you've found a good workaround. You could try setting the button active -wButton.SetFocus (), then send wButton.TypeKeys ("<Space>"). The problem you're seeing might be related to the way your application responds to Silk's Click event. The 4th TRUE argument you're sending on the Click method sends the event at a lower level.

    Hope this helps


    ------------------
    John W Green
    jwgreen@automationexpertise.com
    http://www.automationexpertise.com

  3. #3
    Senior Member
    Join Date
    Jan 2001
    Posts
    750
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: WIERD BEHAVIOUR WITH \"CLICK()\"

    Interesting behaviour. I think the extra argument in the click() function helped clicking this button.

    Should try Click(null,null,null,null,true)
    just for the heck of it.

    ------------------

  4. #4
    Junior Member
    Join Date
    Dec 2002
    Location
    Sacramento, CA USA
    Posts
    6
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: WIERD BEHAVIOUR WITH \"CLICK()\"

    I am faced with the same problem. When script clicks Command Button on VB Form it generates an error. Application under test closes, and Silk generates an error (as it tries to continue with application, but application is not present)I tried the alternative that you guys sugested but it does not seem to be working. Thank you in advance for your help.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 07:44 AM.

Copyright BetaSoft Inc.