SPONSORS:






User Tag List

Results 1 to 2 of 2
  1. #1
    Guest

    VerifyProperties() problem

    Since upgrading from QAP 4.5.1 to SilkTest 5.0, I have had the following problem with the VerifyProperties method for a dialog. I have not modified the method in any way. Here is some of the code for context:

    // NOTE: Both of these dialogs have the same caption and parent. Both are in the same include file.
    window DialogBox BatchImport
    multitag "Import"
    parent Admin


    window FileDlg FileImport
    multitag "~ActiveApp/[DialogBox]Import [PushButton]Open/.."
    PushButton Open
    multitag "Open"
    "$1"
    TextField FileName
    Multitag “File name:”
    “$1152”


    FileImport.VerifyProperties ({...})
    ""
    {...}
    {"Caption","Import"}
    {"Children",[LIST OF WINDOW] {...}}
    FileImport.LookInText
    FileImport.LookInPop
    FileImport.LookInLView
    FileImport.FileNameText
    FileImport.FileName
    FileImport.FilesOfTypeText
    FileImport.FilesOfType
    FileImport.Open
    FileImport.LookInToolBar
    FileImport.Cancel
    FileImport.DialogBox1
    {"DefaultButton",FileImport.Open}
    {"Enabled",TRUE}
    {"Focus",FileImport.FileName}
    {"State",WS_NORMAL}


    In QAP 4.5.1 this VerifyProperties call was always successful. In SilkTest the actual value returned for the “DefaultButton” and “Focus” properties is:

    DefaultButton: BatchImport.PushButton(“Open|$1”)
    Focus: BatchImport.TextField(“File name:|$1152”)

    Does anyone have any ideas about why the VerfiyProperties method is now ‘seeing’ a different dialog (the BatchImport instead of the FileImport) only for some of the properties?

  2. #2
    Senior Member
    Join Date
    Aug 1999
    Location
    MA
    Posts
    129
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: VerifyProperties() problem

    I had the same problem when moving from QA Partner v4.62 to Silk 5.0.

    I don't have any insight as to why it does not work now. I went and changed my "Verify" code to work with Silk 5.0 after spending about an hour trying to "fix" it.
    I have all the scripts under CVS version control, so I tagged my existing scripts at v4.62 level, then ported the code to Silk 5.0.
    Steven Tyler
    Manager - Performance Engineering

    Kronos Incorporated
    tel: +1 978 947 4219

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 09:20 AM.

Copyright BetaSoft Inc.