SPONSORS:






User Tag List

Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    Jan 2001
    Location
    Rochester, NY, USA
    Posts
    16
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    2000 and nt4.0 connectivity problem

    Has any one encountered anything like this, or have a solution? I am running a script from a Pc configured with 2000 pro on it. I am connecting to another PC with nt4.0 on it. If I try to do simple actions like Taskbar.SetActive(), silk gives me an error saying that the SetActive function is not defined for Taskbar. I am running 5.03 patch 2 on both machines and have checked both winclass.inc files to verify that Taskbar was declared for msw2000 and mswnt40. Thanks in advance for any help!

  2. #2
    Senior Member
    Join Date
    Jul 1999
    Location
    Bellingham, WA USA
    Posts
    1,323
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: 2000 and nt4.0 connectivity problem

    Should work. Have you condsidered trying Taskbar.SetFocus()? Try setting the Window itself active.

  3. #3
    Junior Member
    Join Date
    Jan 2001
    Location
    Rochester, NY, USA
    Posts
    16
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: 2000 and nt4.0 connectivity problem

    I guess that my first post was a bit inaccurate. I am trying to set the Taskbar active using Taskbar.SetActive(). I can get other functions to work. However, the same senario can be set using a 98 box. If I launch the script from a 98 or 2000 pro box, connect to the nt40 box and then try to set the Taskbar active, I get "ERROR: Function SetActive is not defined for window Taskbar". I am able to GetGuiType, so I know that Silk is recognizing the platform that it is manipulating.

    DJGray,As far as Setting Focus, this is not a function that is defined for the classes of Taskbar or anywin, so there is no way to use this unless I write a SetFocus() function and Extend either Taskbar class or anywin class. I was hoping for another avenue in case I run into other functions like this. I have just started to try this cross platform thing.

  4. #4
    Senior Member
    Join Date
    Oct 1999
    Location
    Tyngsborough, MA
    Posts
    211
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: 2000 and nt4.0 connectivity problem

    This is a known bug with Silktest. I logged a call on it a while back. They confirmed that it was a bug, but it sounds like they don't plan on fixing it.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 05:48 AM.

Copyright BetaSoft Inc.