SPONSORS:






User Tag List

Results 1 to 4 of 4
  1. #1
    Member
    Join Date
    Nov 2000
    Location
    Shelton, CT, USA
    Posts
    32
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    HtmlPushButton with ... in the caption

    I'm using SilkTest 5.0.3.2 (VO method) on a Win2000 machine, IE5

    Whenever I encounter a HtmlPushButton with a caption which includes ..., SilkTest treats the object as a HtmlText. I realize I can click on a HtmlText, but this does not work consistently. I've tried doing GetRect() and then using a Click (1,rect.xSize / 2,rect.ySize / 2) to assure I click in the center. I've also tried tabbing to the field and doing an 'Enter'. Neither technique consistently works. Sometimes it clicks and sometimes it doesn't.

    Anyone have any ideas how to force SilkTest to recognize this object as a HtmlPushButton, or a way to have SilkTest consistantly click on the HtmlText ?

  2. #2
    Senior Member
    Join Date
    Mar 2000
    Location
    Dublin, Ireland
    Posts
    152
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: HtmlPushButton with ... in the caption

    Hi mvpl,

    In your window declarations try,

    [-] HtmlPushButton Details
    [ ] tag "[HtmlText]Details..."


    Please let me know how you get on.

    John.

    ------------------

    John O'Neill.
    Quality Automation Ltd.
    www.quality-automation.com
    John O'Neill.
    Quality Automation Ltd.
    www.quality-automation.com

  3. #3
    Member
    Join Date
    Nov 2000
    Location
    Shelton, CT, USA
    Posts
    32
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: HtmlPushButton with ... in the caption

    Of course. What was I thinking.
    Works fine.
    Thanks.

    -michael

  4. #4
    Super Member
    Join Date
    Jul 1999
    Location
    Rancho Santa Margarita, CA
    Posts
    1,439
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    1 Thread(s)

    Re: HtmlPushButton with ... in the caption

    As been said before "there are so many 'work-arounds' that you can do in SilkTest that are not documented or taught in class".
    Sometimes, it is best to just keep doing a "trial-and-error thing" and boom! "somehow you'll find yourself saying "hey it works!". Wouldn't it be nice if all these "hundreds and thousands of work-arounds" are documented somewhere?

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 05:55 PM.

Copyright BetaSoft Inc.