SPONSORS:






User Tag List

Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Junior Member
    Join Date
    Mar 2001
    Location
    San Francisco, CA USA
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    \'Read past end of buffer\' error message

    Hello.

    I am currently using Silktest version 5.0.3. I am encountering a problem with Silk. I am getting a peculiar error message and I cannot seem to find the cause of the problem. (See error message below)

    *** Error:Internal error in agent - Read past end of buffer

    Has anyone ever seen this error message before, and can tell me what might cause this problem? Any help is greatly appreciated.

    Thanks

  2. #2
    Super Member
    Join Date
    Jul 1999
    Location
    Rancho Santa Margarita, CA
    Posts
    1,439
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    1 Thread(s)

    Re: \'Read past end of buffer\' error message

    Please give more info regarding your problem.
    Do you encounter the "internal error" message while starting SilkTest or while starting the Agent or while running a script or recording Windows Declarations?
    If this is your first installation, did SilkTest install properly?

  3. #3
    Junior Member
    Join Date
    Mar 2001
    Location
    San Francisco, CA USA
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: \'Read past end of buffer\' error message

    Let me see.....

    I do believe that Silk was installed correctly. I am currently using IE 5.5.

    The problem occurs on a web page displayed through a web portal. The problem occurs when I try to select an item from a selection scroller. If the first item in the scroller is selected, the problem does NOT exist. If any other choices are selected, the chosen item is highlighted, ...then the browser freezes.
    I have to manually kill the browser.

    An interesting note: There are, however, two selection scrollers on the page (2 of the same kind). One is at the top of the page, the other is at the bottom. The window identifier identifies them differently though.

    There are about 18 total items in the scroller. I tried the following tricks, and they seem to work some of the times.

    - Increase the mouse and keyboard delay
    - used Agent.SetOption(OPT_VERIFY_RESPONDING, FALSE)
    before selecting the item in the scroller
    - Issued sleep commands before/after selecting the item.

    Is any of this info useful?

    thanks again!

    jax

  4. #4
    Super Member
    Join Date
    Jul 1999
    Location
    Rancho Santa Margarita, CA
    Posts
    1,439
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    1 Thread(s)

    Re: \'Read past end of buffer\' error message

    jax,

    sounds like you are already doing the right work-around for this problem. The way I did it in one case (a customized Delphi ComboBox) is to use the FindItem () function followed by a Select (iIndex), from the result of the FindItem () followed by a sleep (3) at least. And this whole work-around is within a do..except with the VERIFY_RESPONDING set to FALSE (just like what you are doing).
    You may also want to try the use of the keyboard interface (keystrokes such as the Arrow keys) for selecting your items, if your AUT supports it.

  5. #5
    Junior Member
    Join Date
    Mar 2001
    Location
    San Francisco, CA USA
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: \'Read past end of buffer\' error message

    Gilbert, thanks for your input. I really appreciate it.

    Getting my script to work would be nice. Actually, I was able to work around it for now. But I am really interested to know what caused the '...Read past end of buffer' error message to appear. I've never seen this before. Do you happen to know what might cause this .

    Does anyone know???

    [This message has been edited by jaxlee (edited 03-06-2001).]

  6. #6
    Junior Member
    Join Date
    Jan 2001
    Location
    Sarasota, FL
    Posts
    9
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: \'Read past end of buffer\' error message

    I have encountered this problem multiple times but have never been able to isolate the problem to anything in particular. Interestingly, even though I am using the same machine, with the same software, and running the same scripts, when I get this error, I reboot (power down entirely) and then the script runs just fine. Memory leak possibly? My OS - Win2K, Silk 5.0.3. This doesn't offer much help, but the fact that you are not the only one experiencing this may be somewhat comforting

  7. #7
    Junior Member
    Join Date
    Jan 2001
    Location
    Rochester, NY, USA
    Posts
    16
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: \'Read past end of buffer\' error message

    I also am getting this error. But I am getting it when I am trying to close the AUT with AUT.Close(). Very strange. Prior to the AUT.Close() i am stating (Verify(AUT.Exists(), true) and then closing the AUT.

    I am running 5.032, win2k, and an AUT that is Java Client/Server.

    ------------------

  8. #8
    Member
    Join Date
    May 2001
    Posts
    39
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: \'Read past end of buffer\' error message

    We have also encountered this error several times but in our case "Reboot Works !"

    ------------------

  9. #9
    Junior Member
    Join Date
    Jan 2001
    Location
    Rochester, NY, USA
    Posts
    16
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: \'Read past end of buffer\' error message

    In our case, the default recovery system is able to keep the script going. There is no need to reboot. And the AUT is closed. (see above comments) SO it doesn't really affect the testcase other than logging an error that I must now go and verify in the silk results file.

    ------------------

  10. #10
    Member
    Join Date
    Nov 2000
    Location
    Tampa, FL USA
    Posts
    90
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: \'Read past end of buffer\' error message

    just an FYI - there is no need to call Segue Support about this because they will tell you that IE 5.5 is not supported on SilkTest 5.0.3.2 and that you can either upgrade to ST 5.5 or downgrade your IE to 5.1. We recently had some problems and were told to do this.

    ------------------

 

 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 04:18 AM.

Copyright BetaSoft Inc.