I have made sure to place SilkBean and SilkTest and Swing Jar files in the Classpath of the Solaris machine.

But I'm getting a "App not registered Error" error from client side and "Window not found" from the NT side.

Here is the debug output from the Unix Client machine:

$ java segue.server.SilkBean debug
Waiting for a connection - 2966
Connected Socket[addr=10.1.6.127/10.1.6.127,port=1323,localport=2966]
Message request ID = 20004
Message request ID = 20001
Message request ID = 20003
Message request ID = 20002
Message request ID = 20007
Message request ID = 20009
Message request ID = 20010
Message request ID = 20011
Message request ID = 20012
Message request ID = 20013
Message request ID = 20014
Message request ID = 20016
Message request ID = 20900
Message request ID = 14001
No Apps registered
Message request ID = 14001
No Apps registered
Message request ID = 14001
No Apps registered
Message request ID = 14001
No Apps registered

Here is my UNIX batch file from where the UNIX APP is launched:

#!/bin/sh

# change into script directory
base=`dirname $0`
cd $base

if [ -z "${CLASSPATH}" ] ; then

CLASSPATH="/home.local/komisch/jar/SilkTest_Java2.jar:/home.local/komisch/jar/silkbean.jar:../lib/TrustpointPKIAll.zip:../lib/activation.jar:../lib/ecc_all.jar:../lib/mail.jar:../l ib/classes111.zip:../lib/jhall.jar:../lib/jndiall.jar:../lib/jsdk.jar:../lib/swingall.jar"
else

CLASSPATH="/home.local/komisch/jar/SilkTest_Java2.jar:/home.local/komisch/jar/silkbean.jar:../lib/TrustpointPKIAll.zip:../lib/activation.jar:../lib/ecc_all.jar:../lib/mail.jar:../l ib/classes111.zip:../lib/jhall.jar:../lib/jndiall.jar:../lib/jsdk.jar:../lib/swingall.jar:$CLASSPATH"
fi

export CLASSPATH


echo "Starting CA Wizard..."
../jre1.2.2/bin/java -Xmx80m -Djava.compiler=NONE
com.trustpoint.client.admin.PKIAdmin -config ../admin/ca_wizard.cfg