SPONSORS:






User Tag List

Results 1 to 5 of 5
  1. #1
    Ann
    Ann is offline
    Junior Member
    Join Date
    Jan 2001
    Location
    Redwood shores,CA,USA
    Posts
    2
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Problem with testing Frames

    Hi,
    I am testing a web application with Silk and have been bumping into this issue on a daily basis -
    I have a page which has 3 frames - each taking different slices to load. Unfortunately the control i use next is on the frame that loads the last - so my test bombs - reloading the page doesn't seem to help.
    Has anyone had a similar experience and found a workaround.

    ------------------
    AO
    AO

  2. #2
    Senior Member
    Join Date
    Jul 1999
    Location
    Burlingame CA 94010
    Posts
    502
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Problem with testing Frames

    It wasn't entirely clear what you're trying to do, but you might try using Browser.WaitForReady () between clicks or other manipulation.

    Hope this helps

    ------------------
    John W Green
    jwgreen@automationexpertise.com
    http://www.automationexpertise.com

  3. #3
    Member
    Join Date
    Jan 2001
    Location
    Fairfield, CT, USA
    Posts
    86
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Problem with testing Frames

    Hi
    Try to increase time in Option/Agent application ready timeout.
    Thanks
    Pal

    [This message has been edited by PalS (edited 02-09-2001).]

  4. #4
    bjc
    bjc is offline
    Member
    Join Date
    Jan 2000
    Location
    CT
    Posts
    66
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Problem with testing Frames

    I had run into a similar problem. If Browser.WaitForReady() is not helping, you might want to create a function that waits for a specific object to exist before continuing with your script execution.

    ex: If some of the frames load before others, select an object (ie: pushbutton, etc.) for Silk to wait on before continuing.

  5. #5
    Ann
    Ann is offline
    Junior Member
    Join Date
    Jan 2001
    Location
    Redwood shores,CA,USA
    Posts
    2
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Problem with testing Frames

    Hi,

    Thanks for all the replies.

    With regard to more clarity of what i am actually doing:
    I have a customization page which has 3 frames in it. There is just one frame that has the controls that i need in order to continue with the test. This frame seems to take the longest time to load. I have tried using Browser.WaitForReady() - hasn't helped, the same goes for increasing the Option/Agent application ready timeout.

    I guess i should try the function idea - that waits for a specific object to exist.
    Thank you very much for your inputs.
    Ann
    AO

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 11:11 PM.

Copyright BetaSoft Inc.