SPONSORS:






User Tag List

Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    Oct 2000
    Location
    Norcross, Ga, US
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    IE and NS recognize the same element differently

    In our application we have tabs that a user can click on to change views. In HTML, these tabs are basically just table data cells with a link inside of them. For whatever reason, when capturing or running a script in Netscape, SilkTest recognizes the clickable text as an HTMLHeading. This seems reasonable because the text looks similar to other headings on the page. In IE, however, SilkTest recognizes the clickable text as an HTMLLink. Has anyone else encountered a similar problem? Do you have any suggestions on how I can write a script that will work in NS and IE under these conditions? (hopefully without too much change b/c we have a good sized script library)

    Thanks

  2. #2
    Member
    Join Date
    Oct 1999
    Location
    St. Paul, MN
    Posts
    82
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: IE and NS recognize the same element differently

    I am also interested to see if anyone has a good way of handling this. We came across the same problems months ago just trying to support IE4, and IE5. We've gotten through it so far by using if statements:

    if sExplorerVersion == "IE4"
    do this

    if sExplorerVersion == "IE5"
    do this other thing

    I know this isn't the best solution and definitely adds to the maintenance.

    It's getting more messy now as we are trying to run our suites in multiple O.S.'s and finding objects recognized differently there too.

    Would love to hear how others are handling this - are a lot of people doing cross browser testing successfully? How about O.S.'s?

    Dana



  3. #3
    Junior Member
    Join Date
    Jul 2000
    Location
    Kent, WA USA
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: IE and NS recognize the same element differently

    There is an easy solution to this. Try this.

    HtmlLink MyHtmlLink
    explorer tag "[Some String or Tag element]"
    netscape tag "[Some String or Tag element]"

    ...

    You can have the String element also reference the controls on the page directly, like this:
    explorer tag "MyLinkTag"

    netscape tag "[HtmlTable]MyTableTag/[HtmlColumn]MyTableRowTag/[HtmlLink]MyLinkTag"

    If you tag gets real complex, you may want to dump it into a function call, but the recorder will not see it if you choose Record->Window Identifiers from the menu.

    tag DynaTag()

    DynaTag()
    ...

    Hope that helps.

    ------------------
    DG
    DG

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 09:15 AM.

Copyright BetaSoft Inc.