I have some complex code that was written under SilkPerformer 4.1 which started breaking under SP V. In debugging it, I reduced the problem to a very simple, reproduceable one. While OK in SP 4.1 and 4.5, SP V apparantly broke the ability to tell how many bytes were returned in a WebURL() call. Here is an example transaction:
transaction TestBinaryLoadLength
gsCapturedObject : string(40000);
gnTrueLen : number;
WebParseResponseData(gsCapturedObject,sizeof(gsCap turedObject),"","",gnTrueLen);
writeln("gnTrueLen=" + string(gnTrueLen));
writeln("sizeof(gsCapturedObject)=" + string(sizeof(gsCapturedObject)));
writeln("length of gsCapturedObject=" + string(strlen(gsCapturedObject)));
end TestBinaryLoadLength;

Although I really use this to determine the length of a binary object (like a jpg), I am finding that even trying to determine the number of bytes returned in straight HTML is broken, hence the demo with the Segue homepage.

Proper output (from 4.1 and 4.5) looks like:
length of gsCapturedObject=35526

Improper output (from SP-V) looks like:
length of gsCapturedObject=35526

And gnTrueLen will vary based on emulated browser! Note that it is gnTrueLen that I am really after, as you can't do a strlen() on a binary object and expect accurate results. Note too that I also tried using WebParseDataBound() under SP-V and still get the wrong gnTrueLen for both binary and HTML data.

Any ideas? Anyone else able to recreate this behavior under SP-V or later?