I am trying to install Rational Robot (trial) and installation asks like the following

"To install this product, you must first install version 2.7 of the Microsoft Data Access Components (MDAC) and Open Database Connectivity (ODBC) drivers following the sequence described in Microsoft Knowledge Base Article 216149"

I have Windows XP SP2 on my system. Even I tried with Windows XP SP3. Also I tried with IE 6.0 and IE 7.0 as MDAC support on Microsoft website says IE also Carries MDAC. I tried to download and Run all versions of MDAC but still gets the same problem.

I couldn't find MDAC 2.7 which supports Windows XP from micrsoft web site.

This problem bugs me since long time and I couldn't move forward. All kind hearted, please help me.