SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    Sep 2004
    Location
    missouri
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Verification Point on list box only returns one column

    I have only just begun using Rational Robot. I have a list box in the client/server application that I am testing. I inserted an object data verification point on that list box. The list box contains 346 rows and 17 columns. I am only retrieving one column (the last one) for each of the 346 rows. I would like to retrieve the data from each column for each of the rows. In the tutorial, that is what happened in teh MSFlexGrid. How can I capture all the data in this listbox for a baseline?

  2. #2
    Member
    Join Date
    Aug 2002
    Location
    Pittsburgh, PA
    Posts
    82
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Verification Point on list box only returns one column

    I would like to know if you got a solution. I am having the same problem.
    Matt Michaux

  3. #3
    Member
    Join Date
    Dec 2005
    Location
    Pune
    Posts
    45
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Verification Point on list box only returns one column

    hi try to change the options in object data verification point and apply.

    try this and let me know......

  4. #4
    Member
    Join Date
    Nov 2005
    Location
    Auckland, New Zealand
    Posts
    91
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Verification Point on list box only returns one column

    Hi, I suggest using Tools/Inspector to find out what properties are visible to Robot.

    It may be that you are not using a dynamic VP. Capture/Insert an Object Properties VP as an alternative instead of Object Data - then you will see what properties you can test. It may be that Development needs to sub-class the attributes you're looking for so that Robot can detect them - have you installed all the plugins for your IDE?

    In my experience, a lot of properties (especially in ListViews) use arrays so it may be you are not querying the right array index...
    It's life Jim, but not as we know it

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 10.00%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 04:28 AM.

Copyright BetaSoft Inc.