SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 4 of 4
  1. #1
    SQA Council
    Join Date
    Mar 2001
    Posts
    14,438
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    HTML Cell value.

    User Lagisetti, Prasad (prasad.lagisetti@weyerhaeuser.com.nospam) posted:

    I am not able to run "htmGetTableCellValue" library function.

    I am getting errors

    Here is my code:
    path= "Type=HTMLFrame;HTMLId=main;\;Type=HTMLTable;Index =4"

    Window SetContext, "WindowTag=WEBBrowser", ""
    Browser SetFrame,"Type=HTMLFrame;HTMLId=main",""
    Result1=htmGetTableCellValue(path,5,3)

    But when I use same path for SQAGETPROPERTY, it works fine.

    Any help is appreciated.

    Prasad.

    ---

  2. #2
    SQA Council
    Join Date
    Mar 2001
    Posts
    14,438
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: HTML Cell value.

    User (Paul_Downes@providian.com.nospam) posted:


    Step through the "htmGetTableCellValue" function (and the called functions)
    in debug mode, tell us where the error is generated, and what it entails.

    If you are using IE, consider using the functions in the "IE_Util" library
    on the RU website -
    http://groups.yahoo.com/group/Ration...es/IE_Util.zip

    The process is along these lines:

    'start browser, get its obj handle
    Result = ieStartBrowser()
    'load web page
    Result = ieLoadPage(objBrowser, sHomePage)
    'get doc obj handle
    Set objHTMLDoc = ieGetHTMLDocObj(objBrowser)
    'get table obj handle
    Set objHTMLTable = ieGetTableObject(objHTMLDoc, aTablesRecogStr)
    'retrieve array of table data
    Result = ieGetTableArray(objHTMLTable, saTableData(), iRowCount,
    iColCount)
    'get a table cell
    sCellValue = saTableData(iRowNum, iColNum).innerText

    This above is an approximation, not working code.

    Cheers . . . Paul

    "Lagisetti, Prasad"
    <prasad.lagisetti@weyerh To: "SQA Suite Team Test Users" <sqa-suite-users@lyris.dundee.net>
    aeuser.com> cc:
    Subject: HTML Cell value.
    08/02/2002 11:39 AM
    Please respond to "SQA
    Suite Team Test Users"



    I am not able to run "htmGetTableCellValue" library function.

    I am getting errors

    Here is my code:
    path= "Type=HTMLFrame;HTMLId=main;\;Type=HTMLTable;Index =4"

    Window SetContext, "WindowTag=WEBBrowser", ""
    Browser SetFrame,"Type=HTMLFrame;HTMLId=main",""
    Result1=htmGetTableCellValue(path,5,3)

    But when I use same path for SQAGETPROPERTY, it works fine.

    Any help is appreciated.

    Prasad.

    ---

  3. #3
    SQA Council
    Join Date
    Mar 2001
    Posts
    14,438
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: HTML Cell value.

    User Lagisetti, Prasad (prasad.lagisetti@weyerhaeuser.com.nospam) posted:

    Paul
    Sorry for the delayed response, I was stucked in different testing.

    Here is the message I am getting, when I run in debug mode


    "HTML table cell could not be
    found=Type=HTMLFrame;HTMLID=main;\;Type=HTMLTable; Index=4;\;Type=HTMLTableCe
    ll;Index=1"

    I am getting this message when it is running
    Function htmGetTableData(sTableRecStr as String, aHTMLTable() as
    HTMLTableData) as Integer

    At
    If SQAFindObject(sCellRecStr & "1") <> sqaSuccess Then
    sMessage = "HTML table cell could not be found = " & sCellRecStr &
    "1"
    MsgBox sMessage, (0+16+0),"FUNCTION GetTableData"
    Exit Function
    End If

    -Prasad
    ----------
    From: Paul_Downes@providian.com [SMTP:Paul_Downes@providian.com]
    Sent: Friday, August 02, 2002 7:13 PM
    To: SQA Suite Team Test Users
    Subject: Re: HTML Cell value.


    Step through the "htmGetTableCellValue" function (and the called
    functions)
    in debug mode, tell us where the error is generated, and what it
    entails.

    If you are using IE, consider using the functions in the "IE_Util"
    library
    on the RU website -

    http://groups.yahoo.com/group/Ration...es/IE_Util.zip

    The process is along these lines:

    'start browser, get its obj handle
    Result = ieStartBrowser()
    'load web page
    Result = ieLoadPage(objBrowser, sHomePage)
    'get doc obj handle
    Set objHTMLDoc = ieGetHTMLDocObj(objBrowser)
    'get table obj handle
    Set objHTMLTable = ieGetTableObject(objHTMLDoc,
    aTablesRecogStr)
    'retrieve array of table data
    Result = ieGetTableArray(objHTMLTable, saTableData(),
    iRowCount,
    iColCount)
    'get a table cell
    sCellValue = saTableData(iRowNum, iColNum).innerText

    This above is an approximation, not working code.

    Cheers . . . Paul


    "Lagisetti, Prasad"

    <prasad.lagisetti@weyerh To: "SQA
    Suite Team Test Users" <sqa-suite-users@lyris.dundee.net>
    aeuser.com> cc:

    Subject: HTML
    Cell value.
    08/02/2002 11:39 AM

    Please respond to "SQA

    Suite Team Test Users"




    I am not able to run "htmGetTableCellValue" library function.

    I am getting errors

    Here is my code:
    path= "Type=HTMLFrame;HTMLId=main;\;Type=HTMLTable;Index =4"

    Window SetContext, "WindowTag=WEBBrowser", ""
    Browser SetFrame,"Type=HTMLFrame;HTMLId=main",""
    Result1=htmGetTableCellValue(path,5,3)

    But when I use same path for SQAGETPROPERTY, it works fine.

    Any help is appreciated.

    Prasad.

    ---

  4. #4
    SQA Council
    Join Date
    Mar 2001
    Posts
    14,438
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: HTML Cell value.

    User (Paul_Downes@providian.com.nospam) posted:


    Download the latest version of the "HTML" library, the parameter names were
    changed to remove some confusion. The first parameter for htmGetTableData
    should be the HTMLDocument recognition string. In the pages I tested, the
    cells are children of the HTMLDocument, not the HTMLTable object.

    I recommend you use the "IE_Util" functions rather than the "HTML"
    functions to avoid recognition problems.

    Cheers . . . Paul

    "Lagisetti, Prasad"
    <prasad.lagisetti@weyerh To: "SQA Suite Team Test Users" <sqa-suite-users@lyris.dundee.net>
    aeuser.com> cc:
    Subject: RE: HTML Cell value.
    08/08/2002 02:15 PM
    Please respond to "SQA
    Suite Team Test Users"



    Paul
    Sorry for the delayed response, I was stucked in different testing.

    Here is the message I am getting, when I run in debug mode


    "HTML table cell could not be
    found=Type=HTMLFrame;HTMLID=main;\;Type=HTMLTable; Index=4;
    \;Type=HTMLTableCe
    ll;Index=1"

    I am getting this message when it is running
    Function htmGetTableData(sTableRecStr as String, aHTMLTable() as
    HTMLTableData) as Integer

    At
    If SQAFindObject(sCellRecStr & "1") <> sqaSuccess Then
    sMessage = "HTML table cell could not be found = " & sCellRecStr &
    "1"
    MsgBox sMessage, (0+16+0),"FUNCTION GetTableData"
    Exit Function
    End If

    -Prasad
    ----------
    From: Paul_Downes@providian.com [SMTP:Paul_Downes@providian.com]
    Sent: Friday, August 02, 2002 7:13 PM
    To: SQA Suite Team Test Users
    Subject: Re: HTML Cell value.


    Step through the "htmGetTableCellValue" function (and the called
    functions)
    in debug mode, tell us where the error is generated, and what it
    entails.

    If you are using IE, consider using the functions in the "IE_Util"
    library
    on the RU website -

    [snipped]
    ------------------------------------------------------------------------------
    Warning : The information contained in this message may be privileged and confidential and protected from disclosure. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify us immediately by replying to this message and then delete it from your computer. All e-mail sent to this address will be received by the Providian Financial corporate e-mail system and is subject to archiving and review by someone other than the recipient.

    ================================================== ============================
    ---

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 13.04%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 03:31 AM.

Copyright BetaSoft Inc.