SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 6 of 6
  1. #1
    SQA Council
    Join Date
    Mar 2001
    Posts
    14,438
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Robot causing problems?

    User Marcus Neto (marcus_neto@hotmail.com.nospam) posted:

    Have any of you had an experience where you would get errors when playing
    back a script and when you go back to try and reproduce it manually you
    can't? Have you ever been able to figure out what was causing the problem
    specifically? We have a situation here where wee will get strange errors
    that appear to be due to the interaction between Robot and our app. They are
    unreproducable outside of Robot. And we are getting very frustrated as they
    come and go without any hint of the source of the problem....


    Marcus Neto
    Marcus_Neto@hotmail.com

    __________________________________________________ _______________
    MSN Photos is the easiest way to share and print your photos: http://photos.msn.com/support/worldwide.aspx


    ---

  2. #2
    SQA Council
    Join Date
    Mar 2001
    Posts
    14,438
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Robot causing problems?

    User Kevin Petry (72627.2200@compuserve.com.nospam) posted:

    This behaviour is pretty much true with all test tools.
    You probably need timing delays or methods to make sure the objects are
    ready before effecting a test on them.

    Good example a web page doesnt have to be completely downloaded before you
    can effect a link click.

    ---

  3. #3
    Junior Member
    Join Date
    Aug 2001
    Posts
    5
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Robot causing problems?

    This is just one of the hazards of testing. I have experienced this numbers of times testing Windows client/server apps. It used to happen more often with SQA Robot 6x, but it still happens with Rational Robot 2002. Usually there is a way to change the test to test the functionality without causing the error.

    ------------------

  4. #4
    SQA Council
    Join Date
    Mar 2001
    Posts
    14,438
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Robot causing problems?

    User (david.marsh@gb.abb.com.nospam) posted:

    --0__=80256B73003133F58f9e8a93df938690918c80256B7300 3133F5
    Content-type: text/plain; charset=us-ascii


    Whilst not a Robot issue I remember working with Winrunner I had a problem
    that I thought I couldn't reproduce manually. I narrowed it down to a
    scroll bar. Worked OK manually, or so I tought. When I carefully clicked
    at all poits across the width I found if I clicked exactly on the edge it
    gpf'd the app.

    With Robot we occaisionally shut down the application and restart it. This
    may not be the best approach but it has made running our scripts more
    reliable.

    Dave

    (Embedded "Marcus Neto" <marcus_neto@hotmail.com>
    image moved 01/03/2002 18:38
    to file:
    pic31981.pcx)


    Please respond to "SQA Suite Team Test Users"
    <sqa-suite-users@lyris.dundee.net>

    To: "SQA Suite Team Test Users" <sqa-suite-users@lyris.dundee.net>
    cc:
    Subject: Robot causing problems?

    Security Level:? Internal


    Have any of you had an experience where you would get errors when playing
    back a script and when you go back to try and reproduce it manually you
    can't? Have you ever been able to figure out what was causing the problem
    specifically? We have a situation here where wee will get strange errors
    that appear to be due to the interaction between Robot and our app. They
    are
    unreproducable outside of Robot. And we are getting very frustrated as they
    come and go without any hint of the source of the problem....


    Marcus Neto
    Marcus_Neto@hotmail.com

    __________________________________________________ _______________
    MSN Photos is the easiest way to share and print your photos: http://photos.msn.com/support/worldwide.aspx


    ---

  5. #5
    SQA Council
    Join Date
    Mar 2001
    Posts
    14,438
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Robot causing problems?

    User Marcus Neto (KIvanov@stssystems.com.nospam) posted:

    I've seen this happen many times. You would need to tell us what the AUT is
    written in and what type of object your script is getting stuck on in order
    for us to help.


    Katherin Ivanov
    Quality Assurance Supervisor
    Enterprise 2 Applications

    STS, an NSB Company
    kivanov@stssystems.com
    Tel: (514) 426-0822, ext. 2175

    From: "Marcus Neto" <marcus_neto@hotmail.com>
    Date: Fri, 01 Mar 2002 13:38:15 -0500

    Have any of you had an experience where you would get errors when playing
    back a script and when you go back to try and reproduce it manually you
    can't? Have you ever been able to figure out what was causing the problem
    specifically? We have a situation here where wee will get strange errors
    that appear to be due to the interaction between Robot and our app. They are

    unreproducable outside of Robot. And we are getting very frustrated as they
    come and go without any hint of the source of the problem....


    Marcus Neto
    Marcus_Neto@hotmail.com

    ---

  6. #6
    SQA Council
    Join Date
    Mar 2001
    Posts
    14,438
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Robot causing problems?

    User Marcus Neto (marcus_neto@hotmail.com.nospam) posted:


    Well THe AUT is written in VB and the form is a GroupBox. Funny thing is
    that when we act on it the first time it is recognized as such and then one
    of the problems that we are having is that when we come back to it the
    groupbox is recognized as a thunderform. It also causes other portions of
    the app to go buggy on us. And yes at times it does shut down the app
    without our desire to do so :0 And I restart the app between testing each
    portion of our app. Unfortunatly this is the section where there are a lot
    of dependencies and I have to do A before I can do B.

    Let me know if you think of anything.

    Marcus Neto

    __________________________________________________ _______________
    Join the world’s largest e-mail service with MSN Hotmail. http://www.hotmail.com


    ---

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 12.50%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 01:12 PM.

Copyright BetaSoft Inc.