User ( posted:

I'm conducting performance testing using Performance Studio2000 (LoadTest)
which drives several GUI users (no Virtual Users!!!) through the Robot
Agents provided with Performance Studio. I'm having difficulty using the
Data Pool commands. I'm attempting to use the DP on a shared cursor basis
('exclusive' set to "FALSE"). I've followed the manuals very closely, and
when I run the Robot GUI scripts on a stand alone basis, the datapool
commands respond correctly. (Of course therre's no possible effect of
sharing a cursor in that mode.) When I run the script through LoadTest to
one or more GUI agents, I get the return code "-2", indicating dataPool
'failure' (whatever that means').
In the 'Computer Settings' dialog box (accessed from the PS session screen
by clicking the 'Computers' bigbutton) I've indicated in the 'Local
Directory' field for each agent the entry "C:\Temp" as suggested by the
'help' facility for that dialog box. (without quotes.... If you include
quotes, the session fails during initialization.) I've also gone to the
properties dialog for all the agent machines (Windows NT exclusively at
this stage) and the master controller (also WinNT) and made sure the "C:
\Temp" drive is in the 'Shared As' mode on the 'Sharing' tab, and
'Permissions' set at 'Full Control' for 'Everyone'.

Can anybody advise how to get my DataPool commands not to return 'Failure'?

Eddie Tipton
Blue Cross Minnesota