1. What version of Rational Performance Tester (PC) are you using? ()
Version 8.1.0

2. What is the protocol you are recording?
SOA

3. If HTML - are you using HTML-Advanced with URLs or,
NA

4. If URL mode:
NA

5. Which feature (FPs) or service packs are you using?
SOA plugin

6. VuGen Recording - are you using Old or New Recording Engine?
NA

7. What kind of license do you have -
- Evaluation?

8. If subscription, is subscription current or expired?
NA

9. What platform(s) (PCs) and Operating Systems (Windows-
XP Service pack 3

10. If you have filed a service request with HP/Mercury, what have they told you at this point with respect to your issue?
NA



I'm using the soa plugin. I have imported a WSDL. When I used it on a unsecured web service it all works great.

But now I get the same message over and over again on a secured web service:

a:BadContextToken

The message could not be processed. This is most likely because the action 'FindAvailableCapacity' is incorrect or because the message contains an invalid or expired security context token or because there is a mismatch between bindings. The security context token would be invalid if the service aborted the channel due to inactivity. To prevent the service from aborting idle sessions prematurely increase the Receive timeout on the service endpoint's binding.


I've tried to put the user credentials everywhere. It doesn't seem to work (username and pasword).

I also have to fill in a certificate value somewhere:
<identity>
<certificate encodedValue="AwAAAAEAAAAUAAAAlJqWkUg==" />
</identity>

I have tried to put it everywhere but I still get the same error over and over again.

Please help.