SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Junior Member
    Join Date
    May 2008
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Problems Installing the .NET Add-in

    Hi SQA experts,

    I am trying to test a .NET application but i'm having trouble with the add-in i believe, here's what's happening.

    I've installed QTP 9.5
    I've installed Visual Studio 2003
    I've installed .NET add-in from HP
    I've installed .NET framework 2.0

    All installed successfully. So it all looks good.
    BUT! When I run QTP, on the Add-in selection screen I do not see an option for .NET? am I supposed to?

    Is there any compatibility/version issues with any of the installations mentioned?

    The result of my current configuration is: when I attempt to record the .NET application using QTP it does not identify the objects. It identifies the panels and .click (x,y) which fails if the screen or object changes state.

    Here's an example of the code:

    Browser("Ampla").Window("Edit Downtime Record").WinObject("smartToolBar1").Click 197,12

    I apologise for the vagueness, i'm not sure if this is a QTP issue or an installation issue, can someone please shed some guruness upon thee?

    Cheers,
    Shaun

    Brisbane Australia

  2. #2
    Member
    Join Date
    May 2004
    Posts
    355
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Problems Installing the .NET Add-in

    This may be silly, but did you restart your box after install.
    Also what kind of license do you have, seat? or concurrent?

  3. #3
    Junior Member
    Join Date
    May 2008
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Problems Installing the .NET Add-in

    Hi Mazztt,
    Yes the machine has been rebooted several times with no success!!

    The licence is concurrent on that machine.

    Any other suggestions from your bag of tricks [img]/images/graemlins/smile.gif[/img]

    Cheers,
    Shaun
    Attached Images Attached Images

  4. #4
    Senior Member
    Join Date
    Jan 2000
    Location
    USA, CA
    Posts
    1,998
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Problems Installing the .NET Add-in

    Wrong order of procedures.

    .NET framework 2.0 should be installed before
    .NET add-in

    Visual Studio 2003 doesn't effect
    on .NET add-in for QTP 9.5, because it uses Framework 1.2

    What to do:

    Uninstall .NET framework 2.0 and
    .NET add-in. Reboot machine.
    Install those components in correct order (reboot machine after each installation).
    Should work.
    If not - check
    C:\Program Files\Mercury Interactive\QuickTest Professional\bin\QtPro.exe.Config
    Here should be correct version, that you've installed:
    <configuration>
    <startup>
    <!--supportedRuntime version="v1.1.4322"/-->
    <supportedRuntime version="v2.0.50727"/>
    </startup>
    </configuration>
    If not, edit it manually.

    Type of license (per seat or concurrent) doesn't matter in this case.

    Janna

  5. #5
    Junior Member
    Join Date
    May 2008
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Problems Installing the .NET Add-in

    Hi Janna,
    Thanks for your input, I really appreciate your time.

    The .NET Framework 2.0 was actually pre-installed on this work machine before the Add-in was installed. My original post was just a list (it wasn't the actually installation order as such) my apologies for the mixup.

    The exe.config file matches what you have above. It still isn't working.

    Can you confirm if you are supposed to see a .NET checkbox in the QTP Add-in Manager section for starters? I do not have that option.

    See attachment on my previous post!

    Cheers,
    Shaun

  6. #6
    Senior Member
    Join Date
    Jan 2000
    Location
    USA, CA
    Posts
    1,998
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Problems Installing the .NET Add-in

    >Can you confirm if you are supposed to see a .NET checkbox in the QTP Add-in Manager section for starters? I do not have that option.
    Sure. It should be checked.
    If not, .NET AddIn is not installed correctly. Or QTP doesn't accept it.

    Also:
    Check Tools --> ObjectIdentification.
    If .NET installed correctly, ".NET Forms" and ".NET WebForms" should be listed there.
    Image is attached.

    I suggest you reinstall .NET addIn right on the top of existing.
    Does QTP works without .NET AddIn?

    Janna
    Attached Images Attached Images

  7. #7
    Junior Member
    Join Date
    May 2008
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Problems Installing the .NET Add-in

    Hey Janna,

    I did a check in my Tools --> OI section and the ".NET Forms" and ".NET WebForms" are not available in that Environment dropdown box.

    I also did an install of the .NET addin again, and i'm not getting any joy! Argh! frustrating.

    Yes QTP works without the .NET AddIn, i just used it to automate a HTML Web Application on this PC before i started the .NET application. It works fine.

    I've actually tried installing the package (QTP 9.5, VS.NET 2003, .NET add-in, and Framework 2.0 comes standard) on a few PC's here at work as well as my standalone PC at home (with a trial Licence) and i'm still not getting those ".NET Forms" and ".NET WebForms" or a selectable .NET add-in option on the Add-in management screen.

    Maybe there's something wrong with the Add-in installer exe i have? Mine's only 1,967 KB, I downloaded it directly from HP (in the ISO) when we purchased Functional Test! Should i try and get another one?


    Thanks again,

    Shaun

  8. #8
    Senior Member
    Join Date
    Jan 2000
    Location
    USA, CA
    Posts
    1,998
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Problems Installing the .NET Add-in

    Info about my .NET My AddIn (for 9.2):

    Size of QuickTest Professional .NET Add-in.msi - 27,862KB
    It is located in the zipped folder (lot of files and folders there).
    Size of Zip is 38,410KB

    Looks like: yes. You have wrong installation source.

    How did you decompress ISO?
    Some program can corrupt it.
    I do it with NERO. No complains about it.

    Janna

  9. #9
    Senior Member
    Join Date
    May 2005
    Location
    Chennai
    Posts
    687
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Problems Installing the .NET Add-in

    Hi,

    If the add-ins is installed properly you can also see the .NET Add-in Readme file

    Start->Programs->QuickTestProfessional->
    Add-ins->.NET Add-in Readme
    With Best Regards
    Yuva

  10. #10
    Junior Member
    Join Date
    May 2008
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Problems Installing the .NET Add-in

    Janna I think we are on to something,

    I've contacted a representative and they said the file should be much larger and so I should be getting a proper install file by the end of the week.

    In the meantime, I've found out the ISO was extracted by one of the IT maintenance guys using Daemon Tools ISO reader.

    I'll touch base back here with a result once I've tried installing the new file!

    Thanks for all your help so far, fingers crossed!

    Shaun

 

 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 9.68%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 01:37 AM.

Copyright BetaSoft Inc.