SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    Jun 2002
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    QTP does not recognize tables in window applicatio

    I am using qtp 9.2 and we have cAD application.In that application, invoking file->properties->get summary information window with data in tables.
    But qtp does not recognize the tables and data.It recognizes the object as winobject.
    Any help is appreciated

  2. #2
    Moderator
    Join Date
    Jul 2005
    Location
    Delhi
    Posts
    15,575
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    7 Thread(s)
    Total Downloaded
    0

    Re: QTP does not recognize tables in window applic

    I guess CAD does support COM objects. You might wanna look at that aspects. Search for CreateObject method on the forum and google and also anout CAD COM

  3. #3
    Junior Member
    Join Date
    Jun 2002
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: QTP does not recognize tables in window applicatio

    Did not understand why createObject should be used?
    can you please explain in detail?

  4. #4
    Moderator
    Join Date
    Jul 2005
    Location
    Delhi
    Posts
    15,575
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    7 Thread(s)
    Total Downloaded
    0

    Re: QTP does not recognize tables in window applic

    I am not saying that it should be used. What i am saying is that in case CAD supports a Automation COM interface Just like excel, word, outlook etc then you use createobject to work with CAD as well but you will have to look up in the CAD manual first to see if any COM automation is supported.

    If it is not supported then you need to look at Adding usder defined objects to OR
    http://www.sqaforums.com/showflat.ph...e=0#Post411073

    If that also does not work then you would need to look in Virtual Objects

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.40 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 12.50%
vBulletin Optimisation provided by vB Optimise v2.7.1 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.3.0 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 03:02 AM.

Copyright BetaSoft Inc.