SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 17
  1. #1
    Moderator
    Join Date
    Jan 2007
    Location
    Pittsburgh, PA
    Posts
    2,497
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Navigate method is not working with QTP 9.1?

    Hi All,

    Currently I am using QTP 8.2 and planning to migrate to 9.1. I installed 9.1 trial version and noticed Navigate method with Browser is not working. It's executing the navigate step without any errors and do nothing. Does any one have a solution for this.

    Thanks,
    Tirumala Reddy

  2. #2
    Moderator
    Join Date
    Jan 2007
    Location
    Pittsburgh, PA
    Posts
    2,497
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Navigate method is not working with QTP 9.1?

    No one else facing this issue?

  3. #3
    Moderator
    Join Date
    Jul 2005
    Location
    Delhi
    Posts
    15,575
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    7 Thread(s)
    Total Downloaded
    0

    Re: Navigate method is not working with QTP 9.1?

    Well my experience with upgrading from 8.2 to 9.1 was not good for the trial version. I would suggest you to un-uninstall any previous version of QTP (v8.x or v9.x) and then install 9.1

  4. #4
    Moderator
    Join Date
    Jan 2007
    Location
    Pittsburgh, PA
    Posts
    2,497
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Navigate method is not working with QTP 9.1?

    Hi Tarun,

    Thanks for your reply.

    My installation on a new machine which i never installed any older versions of QTP on it.

    - Tirumala Reddy

  5. #5
    Moderator
    Join Date
    Jul 2005
    Location
    Delhi
    Posts
    15,575
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    7 Thread(s)
    Total Downloaded
    0

    Re: Navigate method is not working with QTP 9.1?

    Ok, Try running the update application to see if any patches are available or not?

    and try the below code also to see if it works or not

    SystemUtil.Run "iexplore.exe"
    Browser("creationtime:=0").Sync
    Browser("creationtime:=0").Navigate "www.google.com"

  6. #6
    Moderator
    Join Date
    Jan 2007
    Location
    Pittsburgh, PA
    Posts
    2,497
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Navigate method is not working with QTP 9.1?

    Hi Tarun,

    Tried both the things as you recommended.

    1) When i tried to update getting "The Update Service did not find updates for your application."

    2) Executing your code.

    SystemUtil.Run "iexplore.exe"
    Browser("creationtime:=0").Sync
    Browser("creationtime:=0").Navigate "www.google.com"

    It's executing with out any errors and do nothing.

    Thanks,
    Tirumala Reddy

  7. #7
    Moderator
    Join Date
    Jul 2005
    Location
    Delhi
    Posts
    15,575
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    7 Thread(s)
    Total Downloaded
    0

    Re: Navigate method is not working with QTP 9.1?

    I hope you are not using IE7?

  8. #8
    Senior Member
    Join Date
    Oct 2005
    Location
    London, U.K
    Posts
    1,804
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Navigate method is not working with QTP 9.1?

    Does that matter ?

    Navigate method works fine with I.E 7.

  9. #9
    Moderator
    Join Date
    Jan 2007
    Location
    Pittsburgh, PA
    Posts
    2,497
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Navigate method is not working with QTP 9.1?

    I tried with both IE6 and IE7 by installing QTP 9.1 on 2 different machines and it's not working.

    Thanks,

  10. #10
    Moderator
    Join Date
    Jul 2005
    Location
    Delhi
    Posts
    15,575
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    7 Thread(s)
    Total Downloaded
    0

    Re: Navigate method is not working with QTP 9.1?

    Thats real strange...i guess you would be better off asking mercury support to help now.

 

 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 11.54%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 01:52 AM.

Copyright BetaSoft Inc.