SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 6 of 6
  1. #1
    Junior Member
    Join Date
    Nov 2006
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    ChildObject recognition problem

    I'm relatively new to QTP. In my code I was using childobject method to get all links from the site and it worked fine.
    Recently the change was done to the site that added another div with JS code.

    And now when I run my code, QTP can not recognize any object on the page anymore (And I did try a lot of tweaks to make it work). When I use the "Object Spy" to get my Link object recognized the same way, nothing changes, everything is the same:
    Browser -> Page -> Link
    Do I miss something? Do I need to change my setting or anything? Help please.

  2. #2
    Moderator
    Join Date
    Jul 2005
    Location
    Delhi
    Posts
    15,575
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    7 Thread(s)
    Total Downloaded
    0

    Re: ChildObject recognition problem

    Attach the page source code to the post, if you have old one that would be of gr8 help...

  3. #3
    Junior Member
    Join Date
    Nov 2006
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: ChildObject recognition problem

    Set LinkDesc = Description.Create()
    LinkDesc("html tag").Value = "A"

    Set LinkList = Browser("...").Page(".....").ChildObjects(LinkDesc )

    NoOfLinks = LinkList.count
    msgbox NoOfLinks

  4. #4
    Moderator
    Join Date
    Jul 2005
    Location
    Delhi
    Posts
    15,575
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    7 Thread(s)
    Total Downloaded
    0

    Re: ChildObject recognition problem

    I was not talking about the script code but the actual HTML page

  5. #5
    Junior Member
    Join Date
    Nov 2006
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: ChildObject recognition problem

    The problem seems to be related to Offermatica code, mbox JS have been inserted, and when the code is generated Informatica inserts iframes which seems to confuse QTP, and childobject method fails to recognize objects, is there anyway to go around it?

  6. #6
    Junior Member
    Join Date
    Oct 2001
    Location
    Leatherhead, Surrey, UK
    Posts
    5
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: ChildObject recognition problem

    i have the same issue [img]/images/graemlins/frown.gif[/img]

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 11.54%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 10:31 AM.

Copyright BetaSoft Inc.