I have worked with a project for 6 weeks now and the recording when we started did not cause any problems. Now, 6 weeks later the recording of new actions is painfully slow. The tested application slows to a stand-still. The problem is only visible when recording, running scripts is still fairly decent.

Some facts and actions that I have already taken:

1. I have tried setting /Tools/Options/Active Screens to None without any significant increase in performance.

2. I have tried deleting all temporary files from the Local Settings/Temp folder and temporarily that increased performance slightly but it soon degraded.

3. Recording on other applications, e.g. Microsoft Office, is acceptable and is not hit by any performance issues.

4. I have not to my knowledge changed any of the installed software on the computer. The tested software has been upgraded once during the project and recording with Quicktest was acceptable both before and after the version change.

5. We are using local repositories, due to the known performance issues with large repository files.

Any ideas what could be affecting performance in this aspect?


Software and Hardware information

Product name: QuickTest Professional
Product version: 9.0
Product build: 2462
Operating system: Microsoft Windows XP Service Pack 2 (Build 2600)
Internet Explorer version: 6.0.2900.2180

Add-in Information:
Name Version
Visual Basic
.NET (Build 1329)

Patch Information:
Name Readme
QuickTest Professional .NET Add-In 8.2 Patch 2100 QuickTest Professional .NET Add-In 8.2 Patch 2100 Readme

Processor : x86 Family 15 Model 1 Stepping 2 1680 Mhz
Total Physical Memory(RAM) : 767 MB (megabytes)
Available Physical Memory(RAM) : 291 MB (megabytes)