SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 2 of 2
  1. #1
    Junior Member
    Join Date
    Feb 2005
    Location
    Finland
    Posts
    11
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    QTP\'s Multitest Manager and simple log file problem?

    Hello,

    I have created simple log file which works fine with Multitest Manager automation object model when I add my tests to batch separately:
    oMTM.AddTestScript "+ test path"

    but when I load existing batch with same tests
    oMTM.Load "+ path of *.mtm)"
    It gives me an error does not write anything

    Any idea why this is not working when I load existing mtm batch? Html report in both cases
    looks like same.

    My simple logfile code at the end of MTM automation script looks like this:

    'Get the Step interface and retrive information about each test case in the batch run into TestLog text file

    Set fso = CreateObject("Scripting.FileSystemObject")
    set Testlog = fso.CreateTextFile("C:\Automated Test Files\testlog.txt", True)

    Set oReport = oMTM.Report


    For Each Step in oReport.Steps

    If Step.Status = "Test run failed." Then
    Testlog.WriteLine("Failed: " & Step.Script & " /Iteration " & Step.Iteration & "")

    Else

    Testlog.WriteLine("Passed: " & Step.Script & " /Iteration " & Step.Iteration & "")

    End If
    Next

    'Get the Report Information and display information about the overall run into text file

    Testlog.WriteLine("Status: " & oReport.Status & " /Start:" & oReport.StartTime & " /End:" & oReport.EndTime)

    TestLog.Close

  2. #2
    Junior Member
    Join Date
    Mar 2006
    Location
    Switzerland
    Posts
    2
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: QTP\'s Multitest Manager and simple log file problem?

    Hi!

    I've got the same problem as you and I wonder whether you found a solution? I also used
    oMTM.AddTestScript "+ test path"

    and got an error. Also, I don't understand what the use is of setting the Mulit Test Manager preferences to schedule the batch run for a certain time when I have to click Run first and after that cannot open and run other Multi Test Manager instances.

    I hope you can share your experience with me.

    Thanks,
    Lapin

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 11.54%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 03:52 AM.

Copyright BetaSoft Inc.