SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 8 of 8
  1. #1
    Super Member
    Join Date
    Oct 2004
    Posts
    1,222
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Bitmap checkpoints failing Batch test

    Hello fellow QTPers

    I have a problem (Infact I have many, but just one related to QTP).

    I have bitmap checkpoints in my tests and these fail during batch runs (regardless of the tool used for batch testing). They pass when scripts are run individually but fail when more than 3 are run in a batch. The bitmap captured during replay is a black blob. I tried increasing the checkpoint timeout for these to no avail.

    The page seems fine and displays the image on visual inspection. Tried update run as well. Anyone faced a similar problem? Any suggestions?
    (I'm hiring Software Development Engineers in Test in Seattle, WA)

  2. #2
    Senior Member
    Join Date
    Jun 2004
    Location
    Miami,FL
    Posts
    949
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Bitmap checkpoints failing Batch test

    but it is not secure to leave your computer unlock just for testing! on the other hand locking the computer may not be the reason , the test should pass even if you turned off the screen.
    "I realize it's an error, but no one is going to try to do that!"
    From "Top 10 Stupid Comments from Developers".

  3. #3
    Super Member
    Join Date
    Oct 2004
    Posts
    1,222
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Bitmap checkpoints failing Batch test

    I also have the bad habit of minimizing all windows before leaving (subconsciously I like to see my desktop clean when i leave). I could have prolly done that.
    (I'm hiring Software Development Engineers in Test in Seattle, WA)

  4. #4
    Senior Member
    Join Date
    Jan 2000
    Location
    USA, CA
    Posts
    1,998
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Bitmap checkpoints failing Batch test

    >have my screensaver configured so as not to disturb the test
    Mark, HOW, HOW, HOW? Teach me, please!
    I have no such a option, because of Company Security policy :-{
    Could you do that programmatically?
    I prefer to lock my door, but leave computer running all night long ...
    Hi chillyhouse52556,
    test should pass even if you turned off the screen
    Test - yes.
    ScreenShots -NOT
    Regards
    Janna

  5. #5
    Super Member
    Join Date
    Oct 2004
    Posts
    1,222
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Bitmap checkpoints failing Batch test

    Janna,

    If you can't do it the usual way (Right click on desktop>Screensaver>None) then you should probably request your company admin to undo the settings. I mean if it comes in the way of your testing it should be done regardless of company policies.

    You could also try this (not sure again if your company admin has enabled changes to this). Worth a shot tho....

    1. Type gpedit.msc at command line
    2. On the Group Policy tab > Go to 'User Configuration' > 'Administrative Templates' > 'Control Panel' > 'Display'
    3. On the right panel, you should see some options. One of them will be 'Activate Screen Saver' . Disable this. Click Apply, Click Ok. And hope you are done.
    Alternately, you could also use the policy above that one 'Hide Screen saver tab' to unhide the screen saver and make changes.

    Good Luck. Hope this works for you. Try not to make too many changes here. It may **** off your System admin [img]images/icons/smile.gif[/img]
    (I'm hiring Software Development Engineers in Test in Seattle, WA)

  6. #6
    Senior Member
    Join Date
    Jan 2000
    Location
    USA, CA
    Posts
    1,998
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Bitmap checkpoints failing Batch test

    Hi Mark
    Reason for black blob instead of image:
    Screen is not active.
    It happens when ScreenSaver is activating itself after certain period of time, according it setting.
    Or:
    Monitor was turned off, because of CPU setting.

    It happens to my TestCases also,
    during overnight batch running.
    QTP works in background,
    but can not get the images.

    Regards :-}
    Janna

  7. #7
    Super Member
    Join Date
    Oct 2004
    Posts
    1,222
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Bitmap checkpoints failing Batch test

    Aha! My friend Janna to the rescue!

    Janna, I have my screensaver and power settings configured so as not to disturb the test. But I guess I must have locked the computer before leaving for the night. That must be it.

    Spasiba!
    (I'm hiring Software Development Engineers in Test in Seattle, WA)

  8. #8
    Senior Member
    Join Date
    Jan 2000
    Location
    USA, CA
    Posts
    1,998
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Bitmap checkpoints failing Batch test

    Perfect!!!!!!!!!
    Thank you, Mark!
    At least, I can control that.
    I'm not going to break my company rules.
    Of course, NOT .
    But I would be able just turn that off, during some ****** test cycle, when I would
    need all my machines working overnight. :-}
    And restore them back in the morning :-}

    WOW!
    TNX
    Janna

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 7.14%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 03:41 AM.

Copyright BetaSoft Inc.