SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 3 of 3
  1. #1
    Member
    Join Date
    Oct 2003
    Location
    Mumbai
    Posts
    42
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Loading the page on active screen-strange

    Hi friends,

    I have found one very strange behaviour of Astra.

    Browser("DaVinci P1I1").Page("DaVinci P1I1").Frame("menu").Link("AddressUsage").Click
    Browser("DaVinci P1I1").Page("DaVinci P1I1").Frame("contents").WebButton("New").Click
    Browser("DaVinci P1I1").Page("DaVinci P1I1").Frame("contents_2").WebEdit("#AddressUsage# id").Set AddressUsageId
    Browser("DaVinci P1I1").Page("DaVinci P1I1").Frame("contents_2").WebEdit("#AddressUsage# Descri").Set AddressUsageDesp
    Browser("DaVinci P1I1").Page("DaVinci P1I1").Frame("contents_2").WebButton("Ok").Click

    The above is the recorded version. If I place my cursor on any line the corresponding page is loaded to active screen marking the event I have performed. It is perfectly Ok upto this level.

    But, the problem is when I remove the line from that position and placed it in some other location..the page is not loaded.. [img]images/icons/frown.gif[/img]

    At this juncture I would like to ask you how the pages are loaded to active screen ?

    Maybe some of you might have encountered this problem...

    Thanks in advance

    Anand

  2. #2
    Junior Member
    Join Date
    May 2004
    Location
    hyderabad
    Posts
    23
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Loading the page on active screen-strange

    Hi,

    If you use Tree view for dragging the line to another location. then active screen will remain as it is.but if you cut the line in expert view and paste in some other location then reference to the active screen is lost.

    Thanks
    Dantuluri Kiran

  3. #3
    Member
    Join Date
    Jun 2004
    Posts
    84
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Loading the page on active screen-strange

    If you open the (saved) QT script using ordinary text editor (e.g., NotePad), you'll see there are "hidden" codes alongside each "visible" (in QT expert view panel) line. I tend to believe those hidden lines tell QT where to find the corresponding active screen. If you move those hidden lines along with the visible lines, the active screens would move to new positions, too. I tested it just now.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 10.71%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 11:15 AM.

Copyright BetaSoft Inc.