SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 3 of 3
  1. #1
    Apprentice
    Join Date
    Jun 2014
    Posts
    21
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Total Downloaded
    0

    Running test with multiple browsers

    Hello,

    First of all, sorry for my english, it's not my native language Smile

    I have to test a web application whose operation is as follows: after logging in, several pages (3) open and I have to run tests on only one of these windows, but the windows must remain open for normal operation of the application. Registration is going very well. During the test run, click on web buttons works but not when using the weblists. Indeed, QTP does not recognize the page I want.
    How to tell QTP to use only a window (the one with "creationTime" = 2) without closing the others?
    Thank you for your reply.

    PS: I use Windows Seven and QTP11. Previously, tests ran on Windows XP.

  2. #2
    Moderator
    Join Date
    Sep 2001
    Location
    Doncaster, UK
    Posts
    5,788
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0
    As long as QTP is opened before the 3 browsers QTP should create the objects in the OR with the parent browser property of CreationTime = 2 (if you are interacting with the 3rd opened browser as you intimate).

    Is this the behaviour you are seeing?

    When you say QTP doesn't recognise the page, do you mean the page or the Weblist object on the page?

    You can check by running this command:
    Code:
    If Browser("CreationTime:=2").Page("micClass:=Page").Exist Then
        Print "Page Exists"
    Else
        Print "Page Not Exists"
    End If

    Mark Smith

  3. #3
    Apprentice
    Join Date
    Jun 2014
    Posts
    21
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Total Downloaded
    0
    Hello mwsrosso,

    Thank you for your reply! It works perfectly! I put my code inside the if and the test completes successfully.

    Have a good day!

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 12.50%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 12:38 PM.

Copyright BetaSoft Inc.