Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1

    To open eclipse from qtp -"Failed to create java virtual machine"


    I am trying to open eclipse from qtp. While trying to run the step of opening eclipse from qtp, i am getting the following message.
    "Failed to create java virtual machine".

    But when I try to open eclipse manually (without the intervention of qtp) it is working fine.

    I am using UFT11.5

    Please help.

  2. #2

  3. #3
    Thanks for the quick update. I tried the same
    SystemUtil.Run "C:\eclipse\eclipse.exe","","C:\eclipse","open "

    But I am facing the issue. "Failed to create java virtual machine" message appears.

  4. #4
    What are you trying to achieve here? The issues seems to be cause by JAVA add-in that you have installed with QTP

  5. #5
    I am trying to open eclipse from QTP. The issue occurs even without java add-in.

  6. #6
    From QTP Descriptive Programming Unplugged
    Disabling the Java add-in on the machine The Java add-in can be disabled by renaming or disabling the following Windows environment variables: €€1. IBM_JAVA_OPTIONS €€2. _JAVA_OPTIONS €€3. JAVA_TOOL_OPTIONS This will disable the Java add-in on the machine and QTP will not recognize any JAVA application even if the Java add-in is loaded.

  7. #7
    ThankYou. It worked fine. I was able to launch eclipse successfully after disabling the mentioned environment variables.

    But QTP is not able to recognize any java object or open any java application anymore.
    Please help.

  8. #8
    That's what I said in the text. It will not be able to identify anything. You can try an option of uninstalling QTP and re-install it on C:\QTP. It may or may not help

  9. #9
    Ok. Thanks a lot for your help.

  10. #10
    Join Date
    Aug 2006
    Montreal, Qc, Canada
    I had this problem back when I was using QTP 9.5 and JRE 1.5. It seems like the stuff QTP puts in _JAVA_OPTIONS conflicts with Eclipse RCP based applications. What I'm suspecting it that QTP's Java Add-In uses the Java Virtual Machine Profiler Interface (JVMPI) to access the JVM. When I ran Eclipse from the command line with the _JAVA_OPTIONS required by QTP's Java Add-In, I got the following message: "JVMPI not supported with this garbage collector".

    I was able to fix the problem by adding the following option to _JAVA_OPTIONS: -XX:-JVMPICheckGCCompatibility

    However, JVMPI is not included in Java 6 since it's been superseded by JVMTI. Therefore, I think the problem might apply only if you're on Java 5 or earlier. I'm currently running QTP 11 with Java 6 and have no problem recognizing objects in Eclipse, with or without that option.

    Hope this helps.


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
BetaSoft Inc.
All times are GMT -8. The time now is 04:15 PM.

Copyright BetaSoft Inc.