Results 1 to 7 of 7
  1. #1

    qtp inserting spaces into innertext of webtable

    I'm trying to run a script but it is failing to find a particular web table. The table is identified by name, innertext, and html tag. The innertext is a concatenation of all the column headers with .* at the end... so, column headers plus any data. On every machine in the building, except mine, apparently, this value is captured with no spaces between the column names. On my machine, it's captured with a space in between each of the column names and, so, it fails to see the table.

    Anyone run into this before? Anyone have ideas on how to fix it? I know I could change the regex to account for spaces or no spaces but I foresee a lot of maintenance work if this problem persists.

    I have tried rebooting my machine, clearing IE cache, deleting QTP files saved in my user profile. I've compared all of the settings between this machine and another and they seem identical. Next step is uninstall and re-install QTP.

    Dennis Belew

  2. #2

    Re: qtp inserting spaces into innertext of webtable

    Spy the WebTable & check if the Object hierarchy is the same in your machine & another machine.

  3. #3

    Re: qtp inserting spaces into innertext of webtable

    Same hierarchy. The only difference I've found is the spaces between the column names. I don't want to have to reinstall but it's looking like my only option.
    Dennis Belew

  4. #4

    Re: qtp inserting spaces into innertext of webtable

    Do you have the same Browser versions on all machines?

  5. #5

    Re: qtp inserting spaces into innertext of webtable

    Yep, same browser versions on the two machines i'm using. Same operating systems. Same QTP versions and patches, as well.

    I'm leaning toward gremlins as the explanation.
    Dennis Belew

  6. #6

    Re: qtp inserting spaces into innertext of webtable

    After uninstalling IE9 and re-installing it, uninstalling and re-installing QTP, and checking every setting I could think of, a co-worker finally recommended something that worked. I created a new user account on the machine, logged in with it, and everything works perfectly. I've got no clue what is making it do what it's doing but it's apparently a setting saved on my account.

    If I ever figure out what setting that is, I'll be sure to post it. Meanwhile, i'm going to be deleting my account and creating it again.

    Nuke the site from orbit... it's the only way to be sure.
    Dennis Belew

  7. #7

    Re: qtp inserting spaces into innertext of webtable

    Your profile folder in that machine is corrupt. the easiest way to fix this is to login with an admin id and rename the profile folder. Then login back again using your credentials. A new profile folder will be automatically created. The new profile will not habe your older settings. To achieve the same copy the required files from old profile folder to new profile folder. The locations of profile folder varies from OS to OS. For Win7, its location is C:\Users\<user name>.




Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
BetaSoft Inc.
All times are GMT -8. The time now is 05:58 PM.

Copyright BetaSoft Inc.