SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 3 of 3
  1. #1
    Senior Member
    Join Date
    Apr 2005
    Posts
    118
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Test Run settings in Object Model

    Hi All,
    I have created a script using Object model for QTP.
    The options are set for run settings to show Pop-up message when QTP encounters an error.
    The script goes fine, but when any errors are encountered, NO POP UP IS DISPLAYED.
    The test stops at that instant.
    Refer the below code.

    ' Declare the Application object variable
    Dim qtApp 'As QuickTest.Application
    Dim qtTest 'As QuickTest.Test
    Dim qtResultsOpt 'As QuickTest.RunResultsOptions

    Set qtApp = CreateObject("QuickTest.Application")
    qtApp.Launch
    qtApp.Visible = True
    'Open the test driver script
    qtApp.Open "C:\MasterTest", True ' Open the test in read-only mode
    Set qtTest = qtApp.Test
    qtTest.Settings.Run.OnError = "Dialog"

    Set TestParamCollection = qtApp.Test.ParameterDefinitions
    Set ParamSet = TestParamCollection.GetParameters()
    Set rtParam = ParamSet.Item("TestSet") ' Retrieve a specific parameter.
    rtParam.Value = "TBT" ' Change the parameter value.

    qtTest.Run ,,ParamSet
    qtTest.Close
    Set qtResultsOpt = Nothing
    Set qtTest = Nothing
    Set qtApp = Nothing

    Let me know if i have missed anything.

  2. #2
    Moderator
    Join Date
    Oct 2010
    Location
    Norway
    Posts
    3,265
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    1 Thread(s)
    Total Downloaded
    0

    Re: Test Run settings in Object Model

    Refer help ->HP QuickTest Professional Automation Object Model -> OnError Property


    Dialog--QuickTest displays an error message dialog box when an error occurs. You must click a button on the message box to continue or end the run session. This option has no effect when running a test using automation, since when QuickTest is opened via automation, it runs in silent mode, meaning that even if it is visible, message boxes are not opened.
    Rajkumar

  3. #3
    Senior Member
    Join Date
    Apr 2005
    Posts
    118
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Test Run settings in Object Model

    Thanks for the inputs Rajkumar.

    If there is any other way, i can bring in the Dialog / pop-up which can help understand the issue during execution as in normal execution mode.

    Thanks in advance.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 7.69%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 10:06 PM.

Copyright BetaSoft Inc.