SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1
    Member
    Join Date
    Nov 2007
    Posts
    53
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    QTP scripts not executing for WPF application.

    Hi All,

    I am woking with QTP10 & WPF addins.

    Please find the observation:
    1. All the WPF objects on the applications are been recognized by QTP.
    2. Once I add the objects in the OR and try performing any operation(click, scroll) on the application under test by executing QTP script the application crashes.
    3. If I add the objects in the OR and try performing any manual operation(click, scroll) on the application under test the application crashes.
    5. I tried using the descriptive programming in QTP but the above problem still persist.
    6. I filtered out the WPF objects (Only added wpfbuttons/ wpfObjects) to the OR and tried executing the code to check whether the crash of the AUT is due to only specific objects or not, but still the Application crash continued.

    Please let me know if we have any solution for the same.

    Thanks,
    Rohit S.

  2. #2
    Advanced Member
    Join Date
    Nov 2007
    Location
    India
    Posts
    686
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: QTP scripts not executing for WPF application.

    What are the add-ins enabled?

    Ensure you use only WPF add-in and/or any required add-in.
    Kind regards,
    Anand Tambey

    RSS Feed : Break To Make it Better
    A Lazy person could be the best automation professional, if he is not lazy in implementing his ideas to reduce his work. ~Anand Tambey

  3. #3
    Member
    Join Date
    Nov 2007
    Posts
    53
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: QTP scripts not executing for WPF application.

    The Addins are:
    .NET
    ActiveX
    Visualbasic
    Web
    WPF

    I am using 5 addins for my AUT.

    Thanks,
    Rohit S

  4. #4
    Advanced Member
    Join Date
    Nov 2007
    Location
    India
    Posts
    686
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: QTP scripts not executing for WPF application.

    Please uncheck the following Add-ins and try again:-

    ActiveX
    Visualbasic
    Web
    Kind regards,
    Anand Tambey

    RSS Feed : Break To Make it Better
    A Lazy person could be the best automation professional, if he is not lazy in implementing his ideas to reduce his work. ~Anand Tambey

  5. #5
    Member
    Join Date
    Nov 2007
    Posts
    53
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: QTP scripts not executing for WPF application.

    I have unchecked the same but still the problem persist.

    There is one more observation:
    When I try to add WPF objects in the OR only the first time I can execute the code/script to retrieve data from the grid or activate the screen. Once the application get crash (Manually clicking the UI) we tried to re launch the application and execute the code, but the code is not been executed neither it gives any object identification error. The QTP scripts just get stuck/hang.

    Thanks,
    Rohit S

  6. #6
    Advanced Member
    Join Date
    Nov 2007
    Location
    India
    Posts
    686
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: QTP scripts not executing for WPF application.

    Have you tried with only WPF add-in loaded/enabled?
    Kind regards,
    Anand Tambey

    RSS Feed : Break To Make it Better
    A Lazy person could be the best automation professional, if he is not lazy in implementing his ideas to reduce his work. ~Anand Tambey

  7. #7
    Member
    Join Date
    Nov 2007
    Posts
    53
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: QTP scripts not executing for WPF application.

    Yes I have tried with only WPF addins but that to is not working.

    Thanks,
    Rohit S.

  8. #8
    Advanced Member
    Join Date
    Nov 2007
    Location
    India
    Posts
    686
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: QTP scripts not executing for WPF application.

    The valid combination for WPF is WPF + .Net add-in.Ensure only these are enabled.

    Do re-install QTP after clean uninstall(by utility of knowledgeinbox).

    If not resolved by that then you need to raise SR @ HP.Usually WPF experience with QTP is challenging/not stable . You may choose to use "UI Automation" with visual studio.
    Kind regards,
    Anand Tambey

    RSS Feed : Break To Make it Better
    A Lazy person could be the best automation professional, if he is not lazy in implementing his ideas to reduce his work. ~Anand Tambey

  9. #9
    Moderator
    Join Date
    Oct 2010
    Location
    Norway
    Posts
    3,265
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    1 Thread(s)
    Total Downloaded
    0

    Re: QTP scripts not executing for WPF application.

    @Rohit,

    There is a patch "WPF Add-in Extensibility" for QTP 10 and this fixes some object recognition issues. Install this & run the test with .NET & WPF selected.
    Rajkumar

  10. #10
    Member
    Join Date
    Nov 2007
    Posts
    53
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: QTP scripts not executing for WPF application.

    Hi RajKumar,

    I have the "WPF Add-in Extensibility" (QTPNET_00038) patch installed on the machine.

    Thanks,
    Rohit S.

 

 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 10.71%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 01:36 AM.

Copyright BetaSoft Inc.