SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Feb 2008
    Posts
    28
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    QTP 10.00 with IE8 (on XP os)

    We are using QTP 10.00.0.0 build 513 and IE8. Our OS is XP with service pack 3.

    We have a web-based app for which we've written automated tests. These tests were written about 1 month ago. When we execute the tests, QTP sometimes can't see the objects on the screen. Other times, the tests end successfully. We don't encounter this issue with any non-web-based apps.

    Has anybody else encountered this issue? If so, how did you overcome it? Any help with this would be very much appreciated.

  2. #2
    Senior Member
    Join Date
    Sep 2006
    Location
    CA, USA
    Posts
    425
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: QTP 10.00 with IE8 (on XP os)

    We have exact same platforms like yours: XP, QTP10, IE8.

    Here are some questions:

    1. Did you newly upgrade to IE8?
    2. Did you encount the issue when you wrote the script?
    3. What is your Record and Run Setting?
    4. Is your web app new? Does it use AJAX technology?

  3. #3
    Senior Member
    Join Date
    Jul 2004
    Location
    Marietta, Georgia
    Posts
    317
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: QTP 10.00 with IE8 (on XP os)

    And the biggest question: What are the properties being identified in the app versus what is listed in the OR? Are they changing between runs?
    <font color="#6B6B6B">Scott Genevish
    Principal Consultant
    Designed Quality</font>

  4. #4
    Junior Member
    Join Date
    Feb 2008
    Posts
    28
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: QTP 10.00 with IE8 (on XP os)

    We recently upgraded to IE8. However, I just found out our web apps are only optimized for IE6. Most if not all of them are several years old. That might be the real reason we are having issues.

    The properties in the app are not changing between runs; they match what is in the OR.

  5. #5
    Super Member FredMan's Avatar
    Join Date
    Oct 2007
    Location
    Lenexa, Kansas
    Posts
    1,218
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: QTP 10.00 with IE8 (on XP os)

    You may be having sync issues where QTP is ready before the AUT is? Insert some Wait() statements in the areas where the object recognition is failing.
    Onward thru the fog...

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 10.00%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 10:37 AM.

Copyright BetaSoft Inc.