I am encountering a strange General Run Error when my script tries to select a value from an SwfCombobox.

Background: We have received a new build of our application and no changes were made to the window containing the combo boxes.

When I run tests that worked on previous versions of our app against this new build I receive the following:

General Run Error -2147467259 (which is an ODBC error???)

What makes this even more strange: If I open a script, run it against the old version, and then run it against our newer version - the script works fine. But if I close and reopen the script and run it again, I get the General Run Error.

QTP sees all of the objects. I am able to highlight them and I am able to find them in the SOR.

Our environment:

Automation env

QTP 9.5
Add-ins: ActiveX, VB, Web, .NET, WPF & Infragistics TestAdvantage 8.2 CLR 2.0 (no, this control does not contain any Infragistics controls).
Quality Center 9.1


.NET 3.5, C#, VB


SwfWindow("eCareManager™ System").SwfWindow("APACHE® Admission Diagnosis").SwfComboBox("cmbElective").Select CellValue

Has anyone encountered anything similar before? Were you able to find the cause of the problem?

I have searched everywhere and can't find anything. I was on the phone with our tech support provider for about 3 hours on Friday trying to get this resolved with no success.

Any help would be greatly appreciated.