SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    Oct 2008
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    QTP 9.5 not recognizing objects in Oracle app

    I am trying to use QTP 9.5 to automate with an Oracle app that I believe is a 10g JSP form (any way to confirm this by looking at the app?).

    When I attempt to add objects to the repository from the app, everything comes in as a generic "WinObject : Internet Explorer_Server" with no unique properties. When I try the "highlight this object in app" button, the entire form is highlighted.

    I have the add ins for Oracle and Java enabled, among others. Using the IE dev toolbar I have identified one of the objects from my app, and the properties are included here for reference:

    [ QUOTE ]

    background-image (css): url(/OA_HTML/cabo/images/swan/btn-bg1.gif)
    class: x7g
    id: HzPuiCreate
    onlick: submitForm('DefaultFormName',0,{'_FORM_SUBMIT_BUTT ON':'HzPuiCreateGZCPML2Y'});return false
    style: BACKGROUND-IMAGE: url(/OA_HTML/cabo/images/swan/btn-bg1.gif)
    title: Create
    type: submit


    [/ QUOTE ]

    All of the objects seem to have a unique "id" property, I need to be able to key off of that if I'm going to be successful!

    I have spent ~6 hours researching this issue and have not been able to find a resolution, please help!

  2. #2
    Junior Member
    Join Date
    Oct 2008
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: QTP 9.5 not recognizing objects in Oracle app

    I have since learned that the GUI I am dealing with is Oracle r12.

    Does anyone have experience using QTP with Oracle r12?

  3. #3
    Member
    Join Date
    Feb 2008
    Posts
    35
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: QTP 9.5 not recognizing objects in Oracle app

    Hi,

    Could you please try to recognize after uninstalling the Java Addins? Sometimes, Java Add ins cause this issue.
    Please let me know.

    Thanks
    Prabu Sundararaj.

  4. #4
    Junior Member
    Join Date
    Oct 2008
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: QTP 9.5 not recognizing objects in Oracle app

    Thank you for your reply Prabu!

    My trial license has expired and I'm experiencing delays with my official license so I can't try uninstalling the Java add-in yet. When I do I'll post here how it goes.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 11.54%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 09:53 AM.

Copyright BetaSoft Inc.