SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    Mar 2003
    Posts
    2
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    TE gettext problem

    Hi,
    I trying out the TE addin for QTP against the emulators putty and seagull (which is supported). I'm trying to read the text from the emulator screen but the gettext function does not show anything past a blank line. If every line contains something then gettext returns the whole screen, but if there is a blank line gettext only shows the text up to this point. The problem occurred for both emulators. I've played with all the emulator configurations in QTP and on the emulator with no joy. Has anyone else encountered this problem?
    Thanks,
    Shane

  2. #2
    Member
    Join Date
    May 2004
    Posts
    98
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: TE gettext problem

    This seems to be an issue with configuration.

    while configuring, pls assign 80 to columns and 24 to rows

    and, also try using dlls such as EHLAPPI (for Hostexplorer).
    likewise, there are couple of other DLLs (EHLAPi32, WHLLAPI32,..)


    Good Luck.

  3. #3
    Junior Member
    Join Date
    Mar 2003
    Posts
    2
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: TE gettext problem

    I did assign 80 columns and 24 rows. I did not specify a dll because I'm using text only mode. The application under test uses vt100 so we won't be able to use any of the hllapi stuff.

  4. #4
    Junior Member
    Join Date
    Jun 2006
    Location
    Columbia MD USA
    Posts
    14
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: TE gettext problem

    It's really worth the pain of the setup session.

    I've had success with using hllapi (whllapi32 and ellapi32) with VT sessions at a text level. It's better than a non hllapi session. QTP does identify the window as TeWindow and the TeScreen. It makes some difference in the scripting and the results. This is on Vax terminal using mostly VT100.
    I'm testing AS400 and can use the extended hllapi functions.

    Moving back and fourth between the two systems is a challenge.
    Scotty_p

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 10.71%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 12:24 PM.

Copyright BetaSoft Inc.