SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 8 of 8
  1. #1
    Junior Member
    Join Date
    Aug 2003
    Posts
    6
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Why is this object not found error

    I am new to winrunner and i created script the usual way using Context sensitive mode. I think 2 times it ran fine then again I tried to run it said object not found, why is this? What else i need to do before running the script?

  2. #2
    Senior Member
    Join Date
    May 2001
    Location
    Ankh-Morpork
    Posts
    2,882
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Why is this object not found error

    Are you running in GUI-map-per-test mode, or global gui-map mode? If the latter (the way I prefer), you need to save the gui map after you record it, then make sure you insert code at the beginning of your script to load it (GUI_load()).

    Assuming this was the problem, make sure you read the chapters of the User's Guide on working with GUI maps and make sure you understand it (and work through the Tutorial as well - it also goes over this important subject). Understanding what the GUI map is and how to work with it is crucial to getting anywhere with this tool.
    web site | [url=http://www.ebookworm.us/[/url]

    [i]...Sound trumpets! Every trumpet in the host! / Sixty thousand, on these words, sound, so high the mountains sound, and the valleys resound.</i] (The Song of Roland)

  3. #3
    Junior Member
    Join Date
    Aug 2003
    Posts
    6
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Why is this object not found error

    I am running GUI map per test mode, so what do u suggest for this?

    Thanks for the answer

  4. #4
    Moderator JakeBrake's Avatar
    Join Date
    Dec 2000
    Location
    St. Louis - Year 2025
    Posts
    15,609
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Why is this object not found error

    Has the application changed such that the object cannot be found?

    Has the name of the object changed or whatever is used to identify it?

    Does the object show up after WinRunner attempts to access it? If so, you need to look into synchronization. This is described in the User's Guide and the Tutorial.

  5. #5
    Senior Member
    Join Date
    Jun 2004
    Location
    New Zealand
    Posts
    223
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Total Downloaded
    0

    Re: Why is this object not found error

    Don't despair I expect this will be the first of many.
    In order for winrunner to carry out an action on an object it needs to be able to identify it from any other object currently displayed on your PC screen.
    To do this is learns just enough details about.
    These it stores in a map which has a sort of tree structure based on its window.
    In order for it be actioned you must tell WR the window Name (set_window) which also appears to give heads up to the gui map saying these are the only objects if interest at the moment.

    When you come to use the object it uses your logical name and looks up the details then sets off to find the object in the window.
    The Object not found indicates there was no exact match at that time.
    I have had instances where some of the details in the map have been volatile and differed from one execution of the application to the next but are consistent within that execution. I have had some where the objects have been numbered and adding or removing other objects(Builds) has impacted (usually this results in actions on an incorrect objected).

    So what to do?
    put break point on or about the offending line.
    Run the script to this point.
    Fire up gui map editor and look at the details in the map and check to see if they math the objects.

    Once you have established what has changed you will need to decide what to do.
    Options include removing the property from the map.
    This may remove its uniqueness.
    Change the property if it is going to be stable.
    Use a different property.

    If you have understood this I will get you to explain it to me sometime otherwise ask for further clarification with some detail and the friendly forum will leap to your aid.

  6. #6
    Junior Member
    Join Date
    Aug 2003
    Posts
    6
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Why is this object not found error

    I got some idea about what you are saying, but still not completely clear, also I have a javascript mouse over, u know on the web if u go to some tab it automatically drops down and u can select a particular element, that doesn't work either is this because it doesn't consider that as object, if so what is the best way to record, thanks for response..

  7. #7
    Senior Member
    Join Date
    Jun 2004
    Location
    New Zealand
    Posts
    223
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Total Downloaded
    0

    Re: Why is this object not found error

    The mouse over is another issue and you might like to post it as a new thread.
    I have never had to handle those but if some one has you might find it with a search of this forum.
    sorry

  8. #8
    Member
    Join Date
    Oct 2003
    Posts
    31
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Why is this object not found error

    Originally posted by gaby58:
    I got some idea about what you are saying, but still not completely clear, also I have a javascript mouse over, u know on the web if u go to some tab it automatically drops down and u can select a particular element, that doesn't work either is this because it doesn't consider that as object, if so what is the best way to record, thanks for response..
    <font size="2" face="Verdana, Arial, Helvetica">Look, if you are using an edit_set argument for this object. If yes, change it to obj_type.
    I had the same problem with a javascript function and this was the solution.

    Regards
    Dietmat

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 10.00%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 11:53 PM.

Copyright BetaSoft Inc.