SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 7 of 7
  1. #1
    Member
    Join Date
    Jul 2002
    Location
    Australia
    Posts
    83
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Parameters & GUI Objects

    Hi All

    I am getting an error message saying illegal number of parameters. When I added the invoke application to the function list it basically says that the properties in GUI map have changed. Problem when I change the GUI map properties I still get the message even though I have used the GUI spy and the modify button to change the properties. Is the problem with the invoke application or is it with the edit set insert pos function?

    From what I can see from the TSL online help and the function generator I am doing everything right (which obviously I am not). Any ideas would be much appreciated.

    By the way the application is a forte application and I am using the add in.

    Cheers


    ------------------

  2. #2
    Senior Member
    Join Date
    Mar 2002
    Location
    Irvine, CA 92606 USA
    Posts
    384
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Parameters & GUI Objects

    In the words of "Joe Friday", the code ma'm just the code.

    In the words of "Joe McGuire", Show me the code.

    Please create a small Test Script using Notepad as the application and see if you get the same problem using "invoke application".

    Include some code so we can see what's up.


    ------------------
    cranem451 - cranem@addendum.com

  3. #3
    Member
    Join Date
    Jul 2002
    Location
    Australia
    Posts
    83
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Parameters & GUI Objects

    Hiya Crame

    Code is as follows:

    invoke_application("\\\\brcgen01\\genu59001\\genru n.bat","u59005 c: c:\\uds503\\userapp\\u59005\\cl0","c:\uds503",SW_S HOW);


    # G......@ Logon
    set_window ("G.....@ Logon", 30);
    edit_set_insert_pos("sUserId", 1);
    obj_type ("GridField_1","Nasher");
    edit_set_insert_pos("sPassword", 1);
    obj_type ("GridField_1","trucker");
    button_press ("Ok");

    # Command Centre
    win_move ("Command Centre", 75, 62);
    set_window ("Command Centre", 3);
    button_press ("Exit");

    # Question
    set_window ("Question", 6);
    button_press ("Yes");

    Thanks

    ------------------

  4. #4
    Senior Member
    Join Date
    Mar 2002
    Location
    Irvine, CA 92606 USA
    Posts
    384
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Parameters & GUI Objects

    If you use "F-6" key to STEP through the code which line is giving you the error message?

    Why does the start of the Path have 4 "Back Slash's" in front of "brcgen01"?

    What "add-in's" are you loading if any?



    ------------------
    cranem451 - cranem@addendum.com

  5. #5
    Member
    Join Date
    Jul 2002
    Location
    Australia
    Posts
    83
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Parameters & GUI Objects

    Hi Crame

    I am using Forte add in. The reason for the 4 back slashes was because the address line had two and I thought that WinRunner would think that they were special characters.



    ------------------

  6. #6
    Senior Member
    Join Date
    Mar 2002
    Location
    Bangalore,Kar,Ind
    Posts
    112
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Parameters & GUI Objects

    Is recording for opening of the application possible if so you may find the correct invoke_application function parameters in the recorded script.

    if the application is started from dos promt then try using dos_system function to start the application.

    ------------------

  7. #7
    Senior Member
    Join Date
    Jul 2001
    Posts
    216
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Parameters & GUI Objects

    It looks to me like you need a double backslash in the third parameter "c:\uds503".

    I hope this helps.

    ------------------

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 10.00%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 04:30 AM.

Copyright BetaSoft Inc.