SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 6 of 6
  1. #1
    Junior Member
    Join Date
    Jul 2001
    Location
    Illinois
    Posts
    10
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    WinRunner/AS400 testing

    When recording AS400 scripts, (Rumba AS/400 Display), the script playsback fine the first time executing it. Subsequent playbacks of the same script on the same AS/400 screens fails with errors. The errors are not consistent, and seem to change with each playback.
    Any ideas?

    Thanks
    J Campbell

    ------------------

  2. #2
    Moderator JakeBrake's Avatar
    Join Date
    Dec 2000
    Location
    St. Louis - Year 2025
    Posts
    15,609
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: WinRunner/AS400 testing

    <BLOCKQUOTE><font size="1" face="Verdana, Arial, Helvetica">quote:</font><HR>Originally posted by QAJIM:
    When recording AS400 scripts, (Rumba AS/400 Display), the script playsback fine the first time executing it. Subsequent playbacks of the same script on the same AS/400 screens fails with errors. The errors are not consistent, and seem to change with each playback.
    Any ideas?

    Thanks
    J Campbell

    <HR></BLOCKQUOTE>

    What are some of the errors (1 or 2)?
    Is there any synchronization problem?

    ------------------
    JP

  3. #3
    Junior Member
    Join Date
    Jul 2001
    Location
    Illinois
    Posts
    10
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: WinRunner/AS400 testing

    I receive INPUT ERROR dialog box "Cursor in protected area of display."

    ------------------

  4. #4
    Moderator JakeBrake's Avatar
    Join Date
    Dec 2000
    Location
    St. Louis - Year 2025
    Posts
    15,609
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: WinRunner/AS400 testing

    <BLOCKQUOTE><font size="1" face="Verdana, Arial, Helvetica">quote:</font><HR>Originally posted by QAJIM:
    I receive INPUT ERROR dialog box "Cursor in protected area of display."

    <HR></BLOCKQUOTE>

    Going by a previous post, this plays back successfully - once after the recording. Is the app changing something to protect after the script might have updated it?

    Can you or do you - do something in the script to unlock the field?

    Is the cursor in a field that is not referred to in your scripts? Or is it a new field relative to the original recording and first playback?

    ------------------
    JP

  5. #5
    Junior Member
    Join Date
    Jul 2001
    Location
    Illinois
    Posts
    10
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: WinRunner/AS400 testing

    Thanks for the reply. I think the issue is there is a time counter on the AS/400 screen. This time field is constantly changing when keystrokes are entered. I'm trying to find a way to remove this time counter on the AS/400 - is there a way for WinRunner to "blank out" or ignore this field?
    Jim C.

    ------------------

  6. #6
    Moderator JakeBrake's Avatar
    Join Date
    Dec 2000
    Location
    St. Louis - Year 2025
    Posts
    15,609
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: WinRunner/AS400 testing

    <BLOCKQUOTE><font size="1" face="Verdana, Arial, Helvetica">quote:</font><HR>Originally posted by QAJIM:
    Thanks for the reply. I think the issue is there is a time counter on the AS/400 screen. This time field is constantly changing when keystrokes are entered. I'm trying to find a way to remove this time counter on the AS/400 - is there a way for WinRunner to "blank out" or ignore this field?
    Jim C.

    <HR></BLOCKQUOTE>
    there might be a way to synchronize on this. Is this the one in the status bar at the bottom left of the term emulator?


    ------------------
    JP

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 12.50%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 09:50 AM.

Copyright BetaSoft Inc.