Mercury shipped the wr_sql library to me to take a look at, but it did not come with a header file and was giving me an error that it was not a compiled module when I tried to load it in. So I tried to go into the test properties and change the script to a compiled module and got the error that it could not open the header. I went into my existing libraries and got the same error with existing tests that were loading just fine. So then I tried to open a new script and make it a compiled module and still got the same error. The only way that I could get my scripts to load again was to open a brand new test, sweep all the code into the new file, and copy in a header file from my backups on disk. This allows me to load the compiled module, but if I were to go into the test properties I would get this error again and my script would stop loading again (so don't try this at home unless you want to work to get things going again).

I talked to Mercury and they had no idea so I thought I would see if anyone here has seen this.

I am currently running WR6.02 (doing a tool evaluation) and will be getting WR7.0 pretty soon when we make the purchase. I will see if this happen on it too.


Jim Twardowski