Results 1 to 9 of 9
  1. #1

    Oracle DB Statement gets cut off on insertion

    1. What version of LoadRunner (LR) or PerformanceCenter (PC) are you using? (specify which tool LR or PC)
    (LR 9.0)

    2. What is the protocol you are recording?
    (Oracle 2-tier)

    2.1 If .NET, which version of .NET does the app require?

    2.2 If .NET, which version of .NET do you have installed?

    3. If HTML - are you using HTML-Advanced with URLs or,
    (indicate yes/no)

    4. If URL mode:
    - Concurrent groups, or
    - Without Concurrent groups?
    (indicate which)

    5. Which LoadRunner/PerformanceCenter feature (FPs) or service packs are you using?
    (No service packs)

    6. VuGen Recording - are you using Old or New Recording Engine?
    (not sure)

    7. What kind of LoadRunner license do you have -
    - Subscription,
    - Perpetual,
    - Permanent/Unlimited
    - Virtual User days, or
    - Evaluation?

    8. If subscription, is subscription current or expired?
    (substitute your answer here)

    9. What platform(s) (PCs) and Operating Systems (Windows-XP, etc.)? Include version and service packs (SP1 or 2, etc.)
    (Windows XP)

    10. If you have filed a service request with HP/Mercury, what have they told you at this point with respect to your issue?
    (Not yet)

    I am getting the following error:
    Action.c(195): Error: lrdo.c/fjExec: "oexec" LDA/CDA return-code=00933:
    Action.c(195): Error: ORA-00933: SQL command not properly ended
    Action.c(195): lrd_exec: ERROR, return-code=LRDE2009

    Issue is that a very long SQL statement get's cut off as seen in replay log before the error.

    Is there a setting that must be done so that it can accept the longer SQL statement recorded in VUGEN?

  2. #2

    Re: Oracle DB Statement gets cut off on insertion

    I think you have issue with correlation,and can you explain what do you mean by Long SQL Statement from your context, is it inserting/updating millions of record or you are having million lines of SQL statement.
    Either way, for me it sounds like missing correlation.

  3. #3

    Re: Oracle DB Statement gets cut off on insertion

    It's not correlation... the SQL statement is straight forward though long. The script is a copy of one that worked in a development test environment, and is now being used on a pre-production environment. The correlation happens on the last segment of the WHERE clause near the end of the 35 line statement (as parsed by VUGEN)... but the replay log shows the statement gets cutoff near the middle at the FROM portion in the middle of declaring the 3rd table (there are 13 tables in this statement).

    Correlation is to a specific key id, and the error statement isn't an error about the amount of records being received... it is about the SQL command not ending properly.

    I'm hoping there is a buffer size setting where I can increase the size so that it can send the full statement in.

  4. #4

    Re: Oracle DB Statement gets cut off on insertion

    Well your error points to the fact that you have incorrect sql query with you.If the query is working manually most of the time, then I can think to say that issue lies with Vugen.
    Most of cases I have seen that issue lies with incorrect oracle queries and setup given that we use oracle 2 tier on raw and fresh code.
    I dont remember exactly what I did last time to fit bigger size query, maybe you can check this forum, I believe that this was discussed here sometimes back.It was some file which was edited maybe default.cfg or some ini.Maybe you can also check the RTE and Recording Options also.I am sure you will find something to increase the size.

    By the way what client are you using to record ?

  5. #5

    Re: Oracle DB Statement gets cut off on insertion

    Is the SQL broken up in VUGen or all on one line?


  6. #6

    Re: Oracle DB Statement gets cut off on insertion

    Ok... I've tried to respond twice to terri_c message, but it won't post....

    VUGen has broken the SQL into 34 lines, but the replay log shows a single line on playback... though that line suddenly ends in the middle of a table name before the WHERE clause.

  7. #7

    Re: Oracle DB Statement gets cut off on insertion

    You could try putting the code all on one line or into a variable in VUGen and see if it helps.

    I have seen pretty long inputs sent into functions in the Web (HTTP/HTML) scripts. I think opening a ticket with HP would be the way to go as this may be a bug. Hopefully there is a fix or patch they can provide to fix the issue.


  8. #8

    Re: Oracle DB Statement gets cut off on insertion

    Are you somehow getting an embedded null character in the huge string? (That would cause the cut off.)

    Can you break the SQL statement into multiple smaller statements? (Not optimal, but it might get you testing again.)

    Definitely agree with the idea of raising a support request with HP. You may have hit an arbitrary maximum size.
    Unless you are writing a compiler, strtok is NOT the answer.
    See: http://www.sqaforums.com/showflat.ph...=541641#542222

    QAF is still an exercise in self-sufficiency! (Thank JB!)

  9. #9

    Re: Oracle DB Statement gets cut off on insertion

    Can you attach the script as it is with full tracing logs turned on ?
    I doubt this has anything to do with LoadRunner, Did you paste the query as it is in TOAD and saw how it goes ?



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
BetaSoft Inc.
All times are GMT -8. The time now is 07:16 PM.

Copyright BetaSoft Inc.