SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Sep 2006
    Posts
    19
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    correlation issue

    1. What version of LoadRunner (LR) or PerformanceCenter (PC) are you using? (specify which tool LR or PC)
    (LR 9.0)

    2. What is the protocol you are recording?
    (WEB(HTTP/HTML)

    3. If HTML - are you using HTML-Advanced with URLs or,
    (YES)

    4. If URL mode:
    Without Concurrent groups

    5. Which LoadRunner/PerformanceCenter feature (FPs) or service packs are you using?
    (N/A)

    6. VuGen Recording - are you using Old or New Recording Engine?
    (New Recording Engine)

    7. What kind of LoadRunner license do you have -
    - Permanent/Unlimited


    8. If subscription, is subscription current or expired?
    (substitute your answer here)

    9. What platform(s) (PCs) and Operating Systems
    (Windows-XP,version 2002, SP2

    10. If you have filed a service request with HP/Mercury, what have they told you at this point with respect to your issue?
    (N/A)


    Hello Everyone,
    Iam trying to capture a dynamically changing value using correlation,Iam pretty sure that I have the correct left and right boundaries thats the only occurece I see, so did not provide ordinal value,however instead of capturing the actual value the script is capturing the variable name,did anyone run into this issue before I see the following in the replay log for the below code snippet

    ABC number is #{ABC}


    web_reg_save_ param("ABC" ,"LB=<input type=\"text\ " name=\"nsc\" id=\"nsc\" value=\"","RB= \" size=\"10\" maxlength=\" 10\" title=\"Text Input:", LAST);

    lr_message(" \n\n ABC number is #%s\n\n", lr_eval_string( "{ABC}")) ;

    thanks
    Smith

  2. #2
    Moderator
    Join Date
    Aug 2001
    Location
    NC
    Posts
    6,018
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Total Downloaded
    0

    Re: correlation issue

    I note that you have posted this to both the LoadRunner yahoo groups and here in a very short window of time. If you have an issue of high urgency, please contact HP LoadRunner product support as that organization is governed by service level agreements to support your request.
    James Pulley

    Replace ineffective offshore contracts, LoadRunnerByTheHour. Starting @ $19.95/hr USD.

    Put us to the test, skilled expertise is less expensive than you might imagine.

    Twitter: @LoadRunnerBTH @PerfBytes

  3. #3
    Junior Member
    Join Date
    Sep 2006
    Posts
    19
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: correlation issue

    thanks.Not an issue of high urgency,but Iam stuck with a problem and unable to move forward was trying my luck to increase the probability of it getting answered by posting in the forums Iam aware of.

  4. #4
    Moderator
    Join Date
    Jan 2006
    Location
    Charlotte, NC
    Posts
    1,600
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: correlation issue

    toolsmith,

    It looks like you have a space between the RB= and the \". It that is so, that is probably your problem.

    If not use web_set_max_html... to allow a bigger capture, and work on capturing too much.
    Unless you are writing a compiler, strtok is NOT the answer.
    See: http://www.sqaforums.com/showflat.ph...=541641#542222

    QAF is still an exercise in self-sufficiency! (Thank JB!)

  5. #5
    Senior Member
    Join Date
    Jun 2003
    Location
    Stamford, CT
    Posts
    135
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: correlation issue

    As we found in the LoadRunner Yahoo group, you need to have web_reg_save_param BEFORE the HTTP request and lr_message AFTER the HTTP request.

    If there was a problem with web_set_max_html or RB/LB, you would get an error that it can't find the parameter.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 10.00%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 10:37 AM.

Copyright BetaSoft Inc.