SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1
    Member
    Join Date
    Mar 2006
    Posts
    73
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Error while recording a .Net application.

    1. What version of LoadRunner (LR) or PerformanceCenter (PC) are you using? (specify which LR or PC)
    8.4.1
    2. What is the protocol you are recording?
    web(click and script)
    3. If HTML - are you using HTML-Advanced with URLs or,
    (substitute your answer here)
    4. URL mode with Concurrent groups, or
    Yes
    5. URL mode without Concurrent groups?
    (substitute your answer here)
    6. Which LoadRunner/PerformanceCenter feature or service packs are you using?
    8.1 FP 4
    7. What kind of LoadRunner license do you have - Subscription, Perpetual, Virtual User days, or Evaluation? (choose the one that fits your license model - Subscription)
    8. If subscription, is subscription current or expired?
    current
    9. What platform(s) and Operating Systems? Include version and service packs.
    WIN XP Professional
    10. If you have filed a service request with HP/Mercury, what have they told you at this point with respect to your issue?
    As of now no update from HP....

    The situation is like this:-

    The application is a .Net application and the feature for which I am getting the error during recording is when I am trying to build a report.

    I am selecting is Begin Date, End Date and more required fields before clicking on the build report button.

    Once I click build report, application gives the following error:-

    The instruction at "0x10022d22" reference memory at "0x10022d22".
    The memmory could not be "read". Click on OK to terminate the program. and the IE closes and recording terminates..

    I have downloaded patches:-

    LR81P150 - This patch solves a crash caused when web_submit _data is
    parametrized with a very large parameter and RTS parameter "Convert
    to/from UTF8" is on 11/21/2006 8163.1 KB

    LR81FP4P150 - SSRT061280 MA ZDI-CAN-112: Mercury LoadRunner Agent
    8.1 FP4 Stack Overflow

    But there is no luck..please suggest if any one is having clue..

    Thanks,
    -Mishra
    --->A slow order processing engine necessarily means slowly processed orders.

    My LR Profile:-

    http://www.sqaforums.com/showflat.php?Ca...true#Post409718

  2. #2
    Moderator JakeBrake's Avatar
    Join Date
    Dec 2000
    Location
    St. Louis - Year 2025
    Posts
    15,609
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Error while recording a .Net application.

    I think you should file a SR with HP.

  3. #3
    Member
    Join Date
    Mar 2006
    Posts
    73
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Error while recording a .Net application.

    Jake,

    SR is there but there is no update from HP...

    -Mishra
    --->A slow order processing engine necessarily means slowly processed orders.

    My LR Profile:-

    http://www.sqaforums.com/showflat.php?Ca...true#Post409718

  4. #4
    Moderator JakeBrake's Avatar
    Join Date
    Dec 2000
    Location
    St. Louis - Year 2025
    Posts
    15,609
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Error while recording a .Net application.

    Please clarify....
    2. What is the protocol you are recording?
    <font color="red">web(click and script)</font>
    3. If HTML - are you using HTML-Advanced with URLs or,
    (substitute your answer here)
    4. URL mode with Concurrent groups, or
    <font color="red">Yes</font>

    Which is correct? [img]/images/graemlins/smile.gif[/img]

    Also,
    1. is this a think .NET client?
    2. have you tried recording using .NET protocol?

  5. #5
    Member
    Join Date
    Aug 2002
    Posts
    253
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Error while recording a .Net application.

    Yeah, almost sounds like an IE thing. Perhaps uninstalling and reinstalling IE would help? And I assume this error doesn't happen when you're not recording.

    Stuff like this is hard to diagnose, and honestly it'll be tough to get help from anyone but Mercury, and even then they'll have to dig.

    You might even want to try switching machines too. I get an odd, but benign, IE exception on only one machine (happens to be my primary) regarding improper DLLs. So IE corruption can definitely happen on a machine to machine basis.

  6. #6
    Moderator
    Join Date
    Jan 2006
    Location
    Charlotte, NC
    Posts
    1,600
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Error while recording a .Net application.

    To kind of follow on to what Dan said...

    LR Recording and Replay is very subject to the "protection" that you have on your system. (Firewall software, virus scanning software, etc.)

    These types of s/w can easily cause you all measures of problems. The best way to record / replay is on a "naked" box.
    Unless you are writing a compiler, strtok is NOT the answer.
    See: http://www.sqaforums.com/showflat.ph...=541641#542222

    QAF is still an exercise in self-sufficiency! (Thank JB!)

  7. #7
    Member
    Join Date
    Mar 2006
    Posts
    73
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Error while recording a .Net application.

    jake,
    protocol is web(click and script), and recording option is URL based script...and URL advance option create concurrent groups for resource is selected...

    Also,
    1. is this a think .NET client? --&gt; No it is web application.

    2. have you tried recording using .NET protocol? --&gt; No I have not used this..

    This error does not come with I run the application manually....

    Mercury support suggesting:-

    LR81P150 - This patch solves a crash caused
    when web_submit _data is parametrized with
    a very large parameter and RTS
    parameter

    I have already installed this patch in my box, as I was having some problem with data down load in one of my previous project.

    Thanks,
    -Mishra
    ---&gt;A slow order processing engine necessarily means slowly processed orders.

    My LR Profile:-

    http://www.sqaforums.com/showflat.php?Ca...true#Post409718

  8. #8
    Senior Member
    Join Date
    Dec 2006
    Posts
    1,838
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Error while recording a .Net application.

    Try with web protocol.You might be having memory issues.

  9. #9
    Member
    Join Date
    Mar 2006
    Posts
    73
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Error while recording a .Net application.

    I tried with the same in URL mode, here I am able to record... But when I stop recoring it gives script creation failed error message... Let me install IE 7 and check this, how it goes...
    ---&gt;A slow order processing engine necessarily means slowly processed orders.

    My LR Profile:-

    http://www.sqaforums.com/showflat.php?Ca...true#Post409718

  10. #10
    Junior Member
    Join Date
    May 2007
    Posts
    24
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Error while recording a .Net application.

    hi m,

    If your getting error message like this "IE has encountered a problem needs to be closed"

    then this could related

    1.check whether any javaript error in the application
    2. try to rename the profile of your machiene
    3. if the still problem is persisting you can use "processExplorer" this is a microsoft sofrware you have to run this exe on your machiene and caputure the dll's of vugen and ie then compare this things capture which are the dll's encountering with vugen after finidng this try to rename that dll's

    hope this could help

    thanks and regards,
    sateesh.v

 

 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 9.38%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 10:24 AM.

Copyright BetaSoft Inc.