SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Sep 2006
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Error 26377: No match found for requested paramter

    1. What version of LoadRunner or Performance Center are you using?
    LoadRunner 8.1
    2. What is the protocol you are working with?
    HTML/HTTP
    3. Which LoadRunner/Performance Center feature or service packs are you using?
    VuGen 8.1 Feature Pack 3
    4. What kind of LoadRunner license do you have - subscription, perpetual, Virtual User days, or evaluation?
    Subscription
    5. What platform(s) and Operating Systems? Include version and service packs.
    MS Windows Server 2000, Service Pack 4
    6. If you have filed a service request with Mercury, what have they told you at this point with respect to your issue?
    N/A

    Check Balance Scenario for 1300 Vusers: Login into the application -> Go to the Balance History page -> Select the item 'Previous Year' & Click on Submit button.

    I do get the following error "Continuing after Error -26377: No match found for the requested parameter
    "PeopleSoftJSessionID10". Check whether the requested boundaries exist in the response data. Also, if the data you want to save exceeds 1024 bytes, use web_set_max_html_param_len to increase the parameter size" when I run for 1300 Vusers. Bcos of which the related TXN aer failing. This problmes occurs for 1013 VUSERS

    Well the parameters that was set in web_reg_save_param("PeopleSoftJSessionID10",
    "LB/IC=jsessionid=",
    "RB/IC=?",
    "Ord=1",
    "RelFrameId=1",
    "Search=Body",
    LAST);

    But when I ran the script for only for 20 Vusers it worked successfully.
    Please let me know why the problem.
    Is it a performance problem or the script problem

    I did try out the following problem
    1. I had already correlated by clicking the utility provided by LR.
    2. I did increase the web_set_max_html_param_len to 819200. Which I feel is too more.
    3. I did increase the think time to 280 & web_set_timeout ("RECEIVE", "280")
    4. I did find in the VUSERs log for those particular users that no values are recorded in the parameter "PeopleSoftJSessionID10".

  2. #2
    Moderator JakeBrake's Avatar
    Join Date
    Dec 2000
    Location
    St. Louis - Year 2025
    Posts
    15,609
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Error 26377: No match found for requested paramter

    Thank you for following the LoadRunner forum posting instructions.

    You have apparently found a bottleneck. The first question for you:
    Is this an acceptable bottleneck? Other....
    Question for you/clarification for you:
    It seems that you are saying the "web_reg_save_param("PeopleSoftJSessionID10"," is working up until 20 users. Is that correct? Then you also say that this occurs when you reach 1,013 users??

    Either way, if it is working in the LoadRunner script up to a point, then the problem probably (see footnote 1 at end of post) exists in the system under test. Are you or anyone else monitoring the system under test? The first places to look would be at the web and app-servers:
    1) heap sizes
    2) number of jvms
    3) number of jdbc connections
    4) heap pattern
    5) container threads
    6) web component connections should be equal to or less than the http server connections
    ... much more if these are not involved in the root cause ...

    Are these configured properly?
    Is there evidence of maxing out the heap and going beyond?
    Is garbage collection running too frequently and for long periods of time?
    ... and so on...


    Footnote 1:
    There is still a chance that you may be contributing to the issue on your end (not to say the sys-under-test is not the issue - and that it may require tuning or scalabiity work in 2 dimensions), depending upon the answers to the below questions AND the computing power/configuration of the servers-under-test...
    1. How fast are these Vusers executing? (with or without think time)?
    2. Are the Vusers simulating a new user each iteration?

    Finally...
    Increasing the web_set_max_html_param_len to 819200 is just not good - unless one has to deal with .NET and large cumbersome viewstates. Think about that value. Understand the impact of the RAM consumption by the Vusers. This is called "shooting oneself in the foot". [img]/images/graemlins/smile.gif[/img]


  3. #3
    Junior Member
    Join Date
    Sep 2006
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Error 26377: No match found for requested paramter

    Hi Jake,

    Yes the web_reg_save_param for parameter ‘PeopleSoftJSessionID10’ is working fine for all 20 users.
    When I found that the error mentioned above comes for 1013 VUSERS while I had executed my scenario ‘Check Balance’ for 1300 VUSERS.
    I did run the same case for 40 VUSERS & found that the error occurs for 5 VUSERS. And when run for 100Vusers the error occurs for 22Vusers.
    Note: I even noted that this error is not consistent. In the sense that for when we again run for 1300 it some times show this problem for 800 VUSERS

    1. How fast are these Vusers executing? (With or without think time)?
    Well it consumes 1 minute 26 seconds to execute 1 VUSER with think time & only 16 seconds to execute 1 VUSER without think time.
    It consumed 1:11:17 (HH: MM:SS) to execute 1300 VUSER with think time.

    2. Are the Vusers simulating a new user each iteration?
    Yes a new VUSER is been simulated for each iteration.

    Well the increasing of the web_set_max_html_param_len to 819200, was only to check whether that could be of any issue. Well its not. In my script I have set to 10240.

    At that moment we had only captured the NMON Results. The results hasn’t monitored at the

    There are 2 JVM’s on the Test Environment.
    JDBC connection pool: Min 10 and Max 50.
    Web Container (on App Server) Thread Pool: Min 10 Max 75 on both JVM’s.
    Initial Heap Size:
    JVM1: MIN 512 Max 1024
    JVM2: MIN 416 Min Max 720

    DB2 HEAP
    Database heap (4KB) (DBHEAP) = 7000
    Max appl. control heap size (4KB) (APP_CTL_HEAP_SZ) = 2048
    Sort list heap (4KB)(SORTHEAP) = 1500
    SQL statement heap (4KB) (STMTHEAP) = 2048
    Default application heap (4KB) (APPLHEAPSZ) = 512
    Package cache size (4KB) (PCKCACHESZ) = (MAXAPPLS*8)
    Statistics heap size (4KB) (STAT_HEAP_SZ) = 4384
    Max number of active applications (MAXAPPLS) = AUTOMATIC
    Average number of active applications (AVG_APPLS) = 1

    Please let me know whether that error (web_reg_save_param PeopleSoftJSessionID10) is any thing to deal with the script / script configuration problems or it’s related to specific settings that is realted to environment so accordingly can be investigated.

  4. #4
    Moderator JakeBrake's Avatar
    Join Date
    Dec 2000
    Location
    St. Louis - Year 2025
    Posts
    15,609
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Error 26377: No match found for requested paramter

    It appears that it is a bottleneck in the environment.
    I suggest the following:
    Determine how often and how long garbage collection is running. Monitoring by either LoadRunner, SiteScope, or tools used by the SysAdmins should be able to tell you that.
    If load-balancing is being used, what is the method? Are the Vusers being load-balanced properly? Do you need to use IP Spoofing?
    I recommend changing:
    a) both JVMs to 256/768, (what is the reason they are different to begin with? Perhaps there is good reason - if not, change to recommended.)
    b) JDBC Max to 75, and
    c) Consider using another JVM.

    Are the Vusers getting HTTP-500s?
    Are you getting any premature connection shutdowns/closures?

    Note! At this point, the troubleshooting should involve some key technical people on your end. And, by far the largest point here…
    What must the architecture support in terms of transactions and types per second? Are you perhaps putting a load on that goes well beyond what is required?

  5. #5
    Senior Member
    Join Date
    Jan 2002
    Posts
    678
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Error 26377: No match found for requested paramter

    Try setting your web_reg_save_param 'Search' attribut to 'ALL'. Also, when you get an error again log in manually and view the source of the page and see if you have a value.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 11.54%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 01:48 PM.

Copyright BetaSoft Inc.